Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unable to log into Piwik after disabling ranges as period in UI #7615

Closed
mgazdzik opened this Issue Apr 1, 2015 · 2 comments

Comments

Projects
None yet
3 participants
@mgazdzik
Copy link
Contributor

commented Apr 1, 2015

How to reproduce:

  • log into Piwik, set for ex. "last7" as default date, log out,
  • set enabled_periods_UI = day,week,month,year
  • try logging back into Piwik - you should be served an error message saying that period is invalid.
    I guess that in such case, user setting should be ignored and "yesterday" loaded instead or something like that.

Please let me know if this is enough to reproduce issue

@mattab

This comment has been minimized.

Copy link
Member

commented Apr 1, 2015

Thanks for report @mgazdzik

@mnapoli

This comment has been minimized.

Copy link
Contributor

commented Apr 3, 2015

PR: #7623

mnapoli added a commit that referenced this issue Apr 7, 2015

mnapoli added a commit that referenced this issue Apr 9, 2015

#7615 When selecting a disabled period, redirect to the default "yest…
…erday" period

Alternate implementation of #7623

@mattab mattab closed this in #7623 Apr 20, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.