New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Display permanent notification in admin screen for PHP 5.4 warning about EOL #8193

Closed
mattab opened this Issue Jun 23, 2015 · 2 comments

Comments

Projects
None yet
2 participants
@mattab
Member

mattab commented Jun 23, 2015

At some point Piwik will require PHP 5.5. #8156

We need to warn users about this at least 6 months before. Since PHP 5.4 is EOL we can start warning users already. Piwik displays such warning for PHP 5.3 so let's display it for PHP 5.4 as well.

Follows up #3877 #6056 #6275

@mattab mattab added the Task label Jun 23, 2015

@mattab mattab added this to the 3.0.0 milestone Jul 15, 2015

@tsteur

This comment has been minimized.

Show comment
Hide comment
@tsteur

tsteur Jul 29, 2015

Member

FYI: In #8452 I changed the notification about EOL to PHP 5.4 see eg http://builds-artifacts.piwik.org/ui-tests.3.0/14501.7/UIIntegrationTest_admin_user_settings . I removed the message that we will drop support for PHP 5.4. Maybe this issue is already closed.

Member

tsteur commented Jul 29, 2015

FYI: In #8452 I changed the notification about EOL to PHP 5.4 see eg http://builds-artifacts.piwik.org/ui-tests.3.0/14501.7/UIIntegrationTest_admin_user_settings . I removed the message that we will drop support for PHP 5.4. Maybe this issue is already closed.

@mattab

This comment has been minimized.

Show comment
Hide comment
@mattab

mattab Aug 12, 2015

Member

looks good 👍

Member

mattab commented Aug 12, 2015

looks good 👍

@mattab mattab closed this Aug 12, 2015

@mattab mattab modified the milestones: 2.15.0, 3.0.0 Aug 12, 2015

mattab added a commit that referenced this issue Nov 2, 2015

mattab added a commit that referenced this issue Nov 3, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment