New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

unclear message when trying to access resource that requires being logged in #8735

Closed
quba opened this Issue Sep 8, 2015 · 0 comments

Comments

Projects
None yet
2 participants
@quba
Contributor

quba commented Sep 8, 2015

Try to go to:
https://demo2.piwik.org/index.php?module=CoreAdminHome&action=trackingCodeGenerator

It works fine if you are logged in (even without idsite parameter it's selecting the first available site ID).
If you are not, such message is being displayed:

The parameter 'idSite=' is missing from the request.

Expected:
There should be an information, that this resource requires being logged in. After logging in, it should redirect to https://demo2.piwik.org/index.php?module=CoreAdminHome&action=trackingCodeGenerator

@tsteur tsteur added the Bug label Sep 8, 2015

@tsteur tsteur added this to the 2.15.0 milestone Sep 8, 2015

@tsteur tsteur self-assigned this Sep 8, 2015

tsteur added a commit that referenced this issue Sep 8, 2015

refs #8735 show more accurate error message
Instead of invalid site we show "please login"

@diosmosis diosmosis closed this in 3c26115 Sep 8, 2015

@mattab mattab changed the title from Weird message when trying to access resource that requires being logged in to unclear message when trying to access resource that requires being logged in Oct 13, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment