New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Use Python 2.7 for travis tests #13282

Merged
merged 2 commits into from Aug 31, 2018

Conversation

Projects
None yet
4 participants
@sgiehl
Member

sgiehl commented Aug 13, 2018

Atm travis is having more and more problems with installing Python 2.6 and all builds are failing randomly.
As Python 2.7 is preinstalled we should use that instead. That will allow us to remove the dependency for deadsnakes apt source and helps to fix the random failures.

Personally I don't see any advantage in using the old 2.6 here, as the log importer itself runs it's tests on 2.6 to prove it works...

After merging we need to update all .travis.yml files of all our plugins...

@fdellwing

This comment has been minimized.

Contributor

fdellwing commented Aug 13, 2018

Should not break anything here.

@sgiehl

This comment has been minimized.

Member

sgiehl commented Aug 17, 2018

@matomo-org/core-team Anyone having a reason not to merge this?
It would also speed up our builds a little bit, as it doesn't try to fetch deadsnakes source and install python anymore...

@Findus23

This comment has been minimized.

Member

Findus23 commented Aug 17, 2018

Python 2.6 has been end-of-life for 5 years and doesn't support essential features like TLS 1.2, so I'd say we shouldn't support it in any way anymore.

@sgiehl

This comment has been minimized.

Member

sgiehl commented Aug 17, 2018

@Findus23 Sure. But the log analytics currently only works with 2.6 & 2.7. Guess we should already deprecate usage of python 2.x and migrate the log analytics to Python 3 for at least Matomo 4

@Findus23

This comment has been minimized.

Member

Findus23 commented Aug 17, 2018

@sgiehl I agree and as I showed in matomo-org/matomo-log-analytics#205 it doesn't take that many changes to get a version that at least passes all tests in python3

@sgiehl sgiehl force-pushed the python27 branch 3 times, most recently from 229048b to 6f246ec Aug 31, 2018

@sgiehl sgiehl force-pushed the python27 branch from 6f246ec to 02c3e12 Aug 31, 2018

@sgiehl sgiehl merged commit 43ef12d into 3.x-dev Aug 31, 2018

0 of 2 checks passed

continuous-integration/travis-ci/pr The Travis CI build is in progress
Details
continuous-integration/travis-ci/push The Travis CI build is in progress
Details

@sgiehl sgiehl deleted the python27 branch Aug 31, 2018

@mattab mattab modified the milestones: 3.7.0, 3.6.1 Sep 1, 2018

InfinityVoid added a commit to InfinityVoid/matomo that referenced this pull request Oct 11, 2018

Use Python 2.7 for travis tests (matomo-org#13282)
* use python 2.7

* adjust travis submodule
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment