pip installs version 0.91.1 (PyPI entry link wrong?) #171

Closed
ddale opened this Issue Jun 20, 2011 · 3 comments

Comments

Projects
None yet
4 participants
Contributor

ddale commented Jun 20, 2011

Original report at SourceForge, opened Sat Oct 30 12:20:00 2010

$ pip install matplotlib

still installs version 0.91.1

See http://bitbucket.org/ianb/pip/issue/162/pip-installs-an-old-version-of-matplotlib#comment-278887 for more details.
(I think it may be to do with the /download at the end)
and these two closed artifacts which report the same behaviour: #3014946 and #2980805

Owner

efiring commented Jun 21, 2011

I think this has been fixed.

efiring closed this Jun 21, 2011

ycopin commented Jul 20, 2011

AFAIK, this has not been fixed: "pip install matplotlib" still download 0.91.1:

$ pip install -v matplotlib
Downloading/unpacking matplotlib
  Using version 0.91.1 (newest of versions: 0.91.1, 0.91.0, 0.86.2, 0.86.1, 0.86, dev)
  Downloading matplotlib-0.91.1.tar.gz (3.9Mb) 

npinto commented Jul 20, 2011

I'm getting the same behavior/error as @ycopin:

pip install -vUI --no-deps matplotlib
Downloading/unpacking matplotlib
  Using version 0.91.1 (newest of versions: 0.91.1, 0.91.0, 0.86.2, 0.86.1, 0.86, dev)
  Downloading matplotlib-0.91.1.tar.gz (3.9Mb)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment