Incompatibility with latest stable Numpy build (v1.7) #1749

Closed
tantrev opened this Issue Feb 14, 2013 · 3 comments

Comments

Projects
None yet
2 participants
@tantrev

tantrev commented Feb 14, 2013

Greetings,

I just installed the latest stable version of Numpy and am given the following error below after trying to import the finance and pyplot modules from matplotlib:

"RuntimeError: module compiled against API version 8 but this version of numpy is 4"

Any ideas on a possible fix?

Thank you!

@mdboom

This comment has been minimized.

Show comment Hide comment
@mdboom

mdboom Feb 14, 2013

Member

Did you build matplotlib yourself from source, or did you install a pre-built binary?

matplotlib needs to be compiled for a specific version of Numpy. The packages we provide don't yet include Numpy 1.7. You can, however, build from source. You just need to remember to remove the build directory first in order to force a complete recompile.

Member

mdboom commented Feb 14, 2013

Did you build matplotlib yourself from source, or did you install a pre-built binary?

matplotlib needs to be compiled for a specific version of Numpy. The packages we provide don't yet include Numpy 1.7. You can, however, build from source. You just need to remember to remove the build directory first in order to force a complete recompile.

@tantrev

This comment has been minimized.

Show comment Hide comment
@tantrev

tantrev Feb 14, 2013

That did the trick! Stupid me, I should have tried that first. :) Thanks for the help.

tantrev commented Feb 14, 2013

That did the trick! Stupid me, I should have tried that first. :) Thanks for the help.

@mdboom

This comment has been minimized.

Show comment Hide comment
@mdboom

mdboom Feb 14, 2013

Member

No problem! Thanks for the report!

Member

mdboom commented Feb 14, 2013

No problem! Thanks for the report!

@mdboom mdboom closed this Feb 14, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment