Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Fix for #1792 #1794

Merged
merged 2 commits into from Feb 27, 2013

Conversation

Projects
None yet
3 participants
Contributor

astrofrog commented Feb 27, 2013

As of pyparsing 2.0.0, Python 2 is no longer supported, so we need to set an upper limit for the range of versions installable by pip.

As of pyparsing 2.0.0, Python 2 is no longer supported, so we need to…
… set an upper limit for the range of versions installable by pip

@pelson pelson and 1 other commented on an outdated diff Feb 27, 2013

@@ -939,7 +939,7 @@ def get_install_requires(self):
if sys.version_info[0] >= 3:
return ['pyparsing>=2.0.0']
else:
- return ['pyparsing>=1.5.6']
+ return ['pyparsing>=1.5.6,<=1.5.7']
@pelson

pelson Feb 27, 2013

Member

For future proofing should this not be 2.0.0?

@astrofrog

astrofrog Feb 27, 2013

Contributor

Ah, you mean strictly less than 2.0.0?

Contributor

astrofrog commented Feb 27, 2013

@pelson - I fixed the version requirement to make it future proof, on the assumption that the 1.x branch of pyparsing will always remain Python 2 compatible.

Contributor

astrofrog commented Feb 27, 2013

@pelson - it looks like Travis passed, so feel free to merge if you are happy with it.

Owner

mdboom commented Feb 27, 2013

Yeah -- I had thought pip would handle the Python version difference, but apparently not. I think this is the correct fix.

Owner

mdboom commented Feb 27, 2013

Also see the tangentially related #1788

mdboom added a commit that referenced this pull request Feb 27, 2013

@mdboom mdboom merged commit aadc894 into matplotlib:master Feb 27, 2013

1 check passed

default The Travis build passed
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment