Skip to content
DEPRECATED: Provides Open4.popen4 via win32/open3 (win32-open3 behavior from 1.8) on ruby 1.9. Don't use this for new code.
Find file
New pull request
Latest commit b1e6b1c @matschaffer Deprecation warnings
Failed to load latest commit information.
lib/win32 Initial commit Deprecation warnings
win32-open3-19.gemspec Deprecation warnings


Don't use this for new code

This gem is a shim to satisfy a call to Open4.popen4 when trying to run old gems on Ruby 1.9 on Windows.

If you're writing new code that needs popen4 on Ruby 1.9 you can use the Open3.popen3 which actually supports 4 block args on Ruby 1.9. The popen4 gem should also work but I haven't personally tried it.

Something went wrong with that request. Please try again.