Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Deprecation warnings

  • Loading branch information...
commit b1e6b1c4444b461826caa3ad3c4af2bf183bcdd8 1 parent dc5ab20
@matschaffer authored
Showing with 9 additions and 2 deletions.
  1. +7 −0 README.md
  2. +2 −2 win32-open3-19.gemspec
View
7 README.md
@@ -0,0 +1,7 @@
+# DEPRECATED
+
+# Don't use this for new code
+
+This gem is a shim to satisfy a call to Open4.popen4 when trying to run old gems on Ruby 1.9 on Windows.
+
+If you're writing new code that needs popen4 on Ruby 1.9 you can use the Open3.popen3 which actually supports 4 block args on Ruby 1.9. The popen4 gem should also work but I haven't personally tried it.
View
4 win32-open3-19.gemspec
@@ -1,7 +1,7 @@
Gem::Specification.new do |s|
s.name = 'win32-open3-19'
- s.version = '0.0.1'
- s.summary = 'Provides Open4.popen4 in Ruby 1.9 on windows'
+ s.version = '0.0.2'
+ s.summary = "DEPRECATED: Provides Open4.popen4 via win32/open3 (win32-open3 behavior from 1.8) on ruby 1.9. Don't use this for new code."
s.author = 'Mat Schaffer'
s.email = 'mat@schaffer.me'
Please sign in to comment.
Something went wrong with that request. Please try again.