README.md

ansible-isucon/isucon4-qualifier

Overview

Ansible playbook for ISUCON4-qualifier

Requirement

  • CentOS 6.x

Usage

Remote:

git clone https://github.com/matsuu/ansible-isucon.git
cd ansible-isucon/isucon4-qualifier
echo 192.0.2.1 > hosts
ansible-playbook -i hosts playbook.yml

Local:

yum install -y epel-release git
yum install -y ansible
git clone https://github.com/matsuu/ansible-isucon.git
cd ansible-isucon/isucon4-qualifier
ansible-playbook -i local playbook.yml

本来の設定と異なるところ

  • MySQLのバージョンを5.5.42からMySQL GA最新版(現在は5.6系)に変更しています
  • nginxのバージョンを1.6.1からstable最新版に変更しています
  • ログインユーザをec2-userからvagrantに変更しています
  • ベンチマークプログラムのインスタンスチェックを削除しています

References