Permalink
Browse files

Merge pull request #56 from matthewrudy/ruby-1.9.3+

Fix tests for Ruby < 1.9.3
  • Loading branch information...
2 parents 01bff4d + 1935565 commit ee1914bc760c4aa8195864fa6e7baf3ba2e88ef6 @matthewrudy committed on GitHub Oct 21, 2016
Showing with 15 additions and 7 deletions.
  1. +10 −6 .travis.yml
  2. +5 −1 memoist.gemspec
View
@@ -6,12 +6,16 @@ rvm:
- 1.9.2
- 1.9.3
- 2.0.0
- - 2.1.0
- - 2.2.0
- - 2.3.0
+ - 2.1.10
+ - 2.2.5
+ - 2.3.1
+ - ruby-head
- jruby-18mode
- jruby-19mode
- - rbx-2
- - ruby-head
+ - jruby-9.1.5.0
- jruby-head
- - ree
+
+before_install:
+ - gem install bundler --no-document -v '~> 1.13'
+before_script:
+ - unset JRUBY_OPTS
View
@@ -34,6 +34,10 @@ Gem::Specification.new do |spec|
spec.add_development_dependency "benchmark-ips"
spec.add_development_dependency "bundler"
- spec.add_development_dependency "rake"
+ if RUBY_VERSION < '1.9.3'
+ spec.add_development_dependency "rake", "~> 10.4"
+ else
+ spec.add_development_dependency "rake"
+ end
spec.add_development_dependency "minitest", "~> 5.5.1"
end

0 comments on commit ee1914b

Please sign in to comment.