Chai.js matchers for Konacha
Ruby
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
chai-as-promised @ f094e34
chai-backbone @ 623dd4e
chai-change @ 3c14cf5
chai-changes @ 7192337
chai-colors @ ea0be06
chai-datetime @ 93a6714
chai-factories @ 668e987
chai-fuzzy @ 0e66b15
chai-jq @ b62223c
chai-jquery @ 3700a64
chai-js-factories @ 974e43a
chai-json-schema @ 5e2d390
chai-null @ 54eb3e4
chai-param @ 992f785
chai-shallow-deep-equal @ c76a9c4
chai-spies @ 85b56f8
chai-stats @ dd901dc
chai-string @ 1d4bbef
chai-subset @ 497b82b
chai-things @ 318ac18
chai-timers @ deaa540
chai-xml @ 2acbc84
js-factories @ 6c3765f
lib
memo-is @ 1bbf417
mocha-as-promised @ a99352d
sinon @ 68bcf73
sinon-chai @ f63422a
tasks
vendor/assets/javascripts
.gitignore
.gitmodules
.ruby-version
Gemfile
LICENSE
README.md
Rakefile
VERSIONS
VERSIONS.lock
konacha-chai-matchers.gemspec

README.md

Konacha Chai Matchers

Gem Version

This library contains all Chai.js plugins that have browser support.

Not all plugins are tested!

Installation

Add in the Gemfile:

gem 'konacha-chai-matchers'

Usage

  1. Check the vendor/assets/javascripts
  2. Require the files needed

Example:

#= require sinon
#= require chai-changes
#= require js-factories
#= require chai-backbone
#= require chai-jquery

Included versions

See VERSIONS for info

Contribution

Please submit an Github issue for libraries you want included or where the wrong file ends up in the vendor folder.

Updating the vendor libraries is done through rake update

please check tasks/update.rb for the code