Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Accept faradey 0.7.x and 0.6.x #13

Merged
merged 1 commit into from

2 participants

@fxposter

Some gems now uses faradey 0.7.x and restricts to that version. I'd like foursquare2 not to explicitly depend on faradey 0.6.x, but also allow 0.7.x. It seems like tests are passing on 0.7 version.

@mattmueller mattmueller merged commit 3c4c0bb into from
@mattmueller
Owner

Thanks for this, verifying the green test run and then releasing a new version.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Aug 24, 2011
  1. @fxposter
This page is out of date. Refresh to see the latest.
Showing with 29 additions and 29 deletions.
  1. +2 −2 Gemfile
  2. +12 −12 Gemfile.lock
  3. +15 −15 foursquare2.gemspec
View
4 Gemfile
@@ -3,8 +3,8 @@ source "http://rubygems.org"
# Example:
# gem "activesupport", ">= 2.3.5"
-gem 'faraday', '~> 0.6'
-gem 'faraday_middleware', '~> 0.6'
+gem 'faraday', '>= 0.6', '< 0.8'
+gem 'faraday_middleware', '>= 0.6', '< 0.8'
gem 'hashie', '~> 1.0'
View
24 Gemfile.lock
@@ -3,24 +3,24 @@ GEM
specs:
addressable (2.2.6)
fakeweb (1.3.0)
- faraday (0.6.1)
- addressable (~> 2.2.4)
+ faraday (0.7.4)
+ addressable (~> 2.2.6)
multipart-post (~> 1.1.0)
- rack (< 2, >= 1.1.0)
- faraday_middleware (0.6.3)
- faraday (~> 0.6.0)
+ rack (>= 1.1.0, < 2)
+ faraday_middleware (0.7.0)
+ faraday (~> 0.7.3)
git (1.2.5)
hashie (1.0.0)
- jeweler (1.6.0)
- bundler (~> 1.0.0)
+ jeweler (1.6.4)
+ bundler (~> 1.0)
git (>= 1.2.5)
rake
jnunemaker-matchy (0.4.0)
json_pure (1.5.1)
multi_json (1.0.2)
- multipart-post (1.1.1)
- rack (1.2.2)
- rake (0.8.7)
+ multipart-post (1.1.3)
+ rack (1.3.2)
+ rake (0.9.2)
rcov (0.9.9)
shoulda (2.11.3)
@@ -30,8 +30,8 @@ PLATFORMS
DEPENDENCIES
bundler (~> 1.0)
fakeweb (~> 1.3)
- faraday (~> 0.6)
- faraday_middleware (~> 0.6)
+ faraday (>= 0.6, < 0.8)
+ faraday_middleware (>= 0.6, < 0.8)
hashie (~> 1.0)
jeweler (~> 1.5)
jnunemaker-matchy (~> 0.4)
View
30 foursquare2.gemspec
@@ -8,10 +8,10 @@ Gem::Specification.new do |s|
s.version = "1.1.0"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Matt Mueller", "Marco Moura"]
- s.date = %q{2011-05-25}
+ s.authors = [%q{Matt Mueller}, %q{Marco Moura}]
+ s.date = %q{2011-08-24}
s.description = %q{Gives access to all endpoints in version 2 of foursquare's API with syntax that will be familiar to those who used the original foursquare gem by Jeremy Welch.}
- s.email = ["muellermr@gmail.com", "email@marcomoura.com"]
+ s.email = [%q{muellermr@gmail.com}, %q{email@marcomoura.com}]
s.extra_rdoc_files = [
"LICENSE.txt"
]
@@ -62,17 +62,17 @@ Gem::Specification.new do |s|
"test/test_venues.rb"
]
s.homepage = %q{http://github.com/mattmueller/foursquare2}
- s.licenses = ["MIT"]
- s.require_paths = ["lib"]
- s.rubygems_version = %q{1.4.2}
+ s.licenses = [%q{MIT}]
+ s.require_paths = [%q{lib}]
+ s.rubygems_version = %q{1.8.6}
s.summary = %q{Foursquare API v2 gem in the spirit of the original foursquare gem}
if s.respond_to? :specification_version then
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<faraday>, ["~> 0.6"])
- s.add_runtime_dependency(%q<faraday_middleware>, ["~> 0.6"])
+ s.add_runtime_dependency(%q<faraday>, ["< 0.8", ">= 0.6"])
+ s.add_runtime_dependency(%q<faraday_middleware>, ["< 0.8", ">= 0.6"])
s.add_runtime_dependency(%q<hashie>, ["~> 1.0"])
s.add_development_dependency(%q<shoulda>, [">= 0"])
s.add_development_dependency(%q<bundler>, ["~> 1.0"])
@@ -81,10 +81,10 @@ Gem::Specification.new do |s|
s.add_development_dependency(%q<fakeweb>, ["~> 1.3"])
s.add_development_dependency(%q<jnunemaker-matchy>, ["~> 0.4"])
s.add_development_dependency(%q<json_pure>, ["~> 1.4"])
- s.add_development_dependency(%q<multi_json>, [">= 0.0.5", "< 2.0.0"])
+ s.add_development_dependency(%q<multi_json>, ["< 2.0.0", ">= 0.0.5"])
else
- s.add_dependency(%q<faraday>, ["~> 0.6"])
- s.add_dependency(%q<faraday_middleware>, ["~> 0.6"])
+ s.add_dependency(%q<faraday>, ["< 0.8", ">= 0.6"])
+ s.add_dependency(%q<faraday_middleware>, ["< 0.8", ">= 0.6"])
s.add_dependency(%q<hashie>, ["~> 1.0"])
s.add_dependency(%q<shoulda>, [">= 0"])
s.add_dependency(%q<bundler>, ["~> 1.0"])
@@ -93,11 +93,11 @@ Gem::Specification.new do |s|
s.add_dependency(%q<fakeweb>, ["~> 1.3"])
s.add_dependency(%q<jnunemaker-matchy>, ["~> 0.4"])
s.add_dependency(%q<json_pure>, ["~> 1.4"])
- s.add_dependency(%q<multi_json>, [">= 0.0.5", "< 2.0.0"])
+ s.add_dependency(%q<multi_json>, ["< 2.0.0", ">= 0.0.5"])
end
else
- s.add_dependency(%q<faraday>, ["~> 0.6"])
- s.add_dependency(%q<faraday_middleware>, ["~> 0.6"])
+ s.add_dependency(%q<faraday>, ["< 0.8", ">= 0.6"])
+ s.add_dependency(%q<faraday_middleware>, ["< 0.8", ">= 0.6"])
s.add_dependency(%q<hashie>, ["~> 1.0"])
s.add_dependency(%q<shoulda>, [">= 0"])
s.add_dependency(%q<bundler>, ["~> 1.0"])
@@ -106,7 +106,7 @@ Gem::Specification.new do |s|
s.add_dependency(%q<fakeweb>, ["~> 1.3"])
s.add_dependency(%q<jnunemaker-matchy>, ["~> 0.4"])
s.add_dependency(%q<json_pure>, ["~> 1.4"])
- s.add_dependency(%q<multi_json>, [">= 0.0.5", "< 2.0.0"])
+ s.add_dependency(%q<multi_json>, ["< 2.0.0", ">= 0.0.5"])
end
end
Something went wrong with that request. Please try again.