Linux version crashes trying to login to google #8

CptanPanic opened this Issue Jun 10, 2013 · 7 comments


None yet
6 participants

No matter what I put in the google login information, app crashes. This is with .2

pjjjv commented Jun 10, 2013

0.3 on linux is the same

0.4 on linux mint is the same

0.4 crashes on Linux Mint here too.


mauimauer commented Jun 11, 2013

Please try the following:

  • Make sure you have installed a usable build enviroment (gcc, make & co.)
  • Install Node.js (using your favourite package manager, but make sure it's newer than 0.8)
  • Clone the git repo (master branch)
  • Go into the ./data/ directory and run npm install (This will fetch and compile all depenencies of portify)
  • Try running the daemon by executing node app.js in the ./data/ folder
  • Open your favourite browser and go to localhost:3132

@ghost ghost assigned mauimauer Jun 11, 2013

pjjjv commented Jun 12, 2013

This is currently the best way to work on linux. Gets me past the Google Music login. It might take you some figuring out to set up the nodejs build system. Also, you need enough RAM for compilation.

murr4y commented Jun 12, 2013

I get an error when running npm install:

npm ERR! Error: No compatible version found: protobuf@'>=0.8.6- <0.9.0-'
npm ERR! Valid install targets:
npm ERR! ["0.3.0","0.3.1","0.3.2"]

I compiled protobuf 2.4.1 from sources and installed several packages, nothing changes.

dpkg -l | grep protobuf:
ii libprotobuf-dev 2.4.1-3ubuntu1 amd64 protocol buffers C++ library
ii libprotobuf-lite7 2.4.1-3ubuntu1 amd64 protocol buffers C++ library
ii libprotobuf7 2.4.1-3ubuntu1 amd64 protocol buffers C++ library
ii protobuf-c-compiler 0.14-1build2 amd64 protocol buffers C compiler
ii protobuf-compiler 2.4.1-3ubuntu1 amd64 compiler for protocol buffer..
ii python-protobuf 2.4.1-3ubuntu1 amd64 Python bindings for protocol..

Any ideas?

pjjjv commented Jun 12, 2013

Install protobuf with your package manager? I believe that is the only dependency I had to upgrade next to nodejs. Nodejs needs to be from an unstable source (package manager), as the version in the stable package manager is often too old.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment