New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error after updating to Mautic 2.12.0 #5459

Closed
fonini opened this Issue Dec 18, 2017 · 8 comments

Comments

Projects
None yet
5 participants
@fonini

fonini commented Dec 18, 2017

What type of report is this:

Q A
Bug report? Yes
Feature request?
Enhancement?

Description:

I've updated a 2.8 Mautic installation to 2.12.0.
When I try to warm up the cache, I get the following error:

[Doctrine\ORM\Mapping\MappingException] Duplicate definition of column 'id' on entity 'Mautic\CoreBundle\Entity\MessageQueue' in a field or discriminator column mapping.

Q A
Mautic version 2.12.0
PHP version PHP 7.0.22

Steps to reproduce:

  1. php app/console cache:warmup --env=prod
@Bizcrony

This comment has been minimized.

Bizcrony commented Dec 18, 2017

how did you try to update?

@fonini

This comment has been minimized.

fonini commented Dec 18, 2017

Found the solution.

Turns out some files weren't deleted.
Removed the Mautic\CoreBundle\Entity\MessageQueue.php file and it worked.

Thanks.

@fonini fonini closed this Dec 18, 2017

@biplobice

This comment has been minimized.

biplobice commented Jan 31, 2018

I faced same problem on 2.12.1
@fonini Thanks for the tips. It works!
I think this should be fixed in core.

@djschoone

This comment has been minimized.

djschoone commented Mar 2, 2018

solved it for us as well. thnx @fonini

@RCheesley

This comment has been minimized.

Contributor

RCheesley commented Mar 19, 2018

Same problem, I did an update from 2.7.1 to 2.12.2 and I came up against this error when I tried to clear the cache after the update (following a system error on loading mautic).

The suggested fix resolves the problem.

Seems this is perhaps still missing from the migration scripts @escopecz but the bug remains - this issue has been closed?

@Bizcrony

This comment has been minimized.

Bizcrony commented Mar 19, 2018

@RCheesley RCheesley May i try to upgrade for you.

@RCheesley

This comment has been minimized.

Contributor

RCheesley commented Mar 19, 2018

I've already resolved the upgrade following the instructions, thanks for the kind offer @Bizcrony

@Bizcrony

This comment has been minimized.

Bizcrony commented Mar 19, 2018

cheers

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment