Fixed buggy calls to bootstrap-sass #13

Merged
merged 1 commit into from Oct 17, 2012

Conversation

Projects
None yet
5 participants
Contributor

NZGlitch commented Sep 13, 2012

There were 2 calls to gradient-vertical-three-colors where a value was given as a % when bootstrap-sass seems to prefer a decimal (i.e. 90% should be 0.9)

This was causing an error for me: '9000%*% is not a valid css.....'

I was using bootstrap-sass version 2.1.0.0

The bug exists in some other swatches as well.

mulder commented Sep 28, 2012

👍

vojtisek commented Oct 6, 2012

Oh man, you just saved me a few hours of my life. Surprisingly, I couldn't find any piece of information about this bug on the net. Good work and I hope that Maxim will take care of this soon.
Once again - thanks.

V.

Owner

maxim commented Oct 17, 2012

Verified, thanks!

@maxim maxim added a commit that referenced this pull request Oct 17, 2012

@maxim maxim Merge pull request #13 from NZGlitch/fix_cerulean
Fixed buggy calls to bootstrap-sass
e9a6aac

@maxim maxim merged commit e9a6aac into maxim:master Oct 17, 2012

This was referenced Oct 17, 2012

This appears to be broken again.

Owner

maxim commented Mar 18, 2013

@engunneer Where exactly? Not all places need percentage as far as I understood. Are you on latest sass?

Specifically https://github.com/maxim/bootswatch-rails/blob/master/vendor/assets/stylesheets/bootswatch/cerulean/_bootswatch.scss#L127

I'm using Rails 3.2.12, sass 3.2.6, sass-rails 3.2.6, bootstrap-sass 2.1.0.0, bootswatch-rails 0.4.0. changing line 127 of cerulean from 5% to .05 worked for me.

Edit: I updated to Rails 3.2.12, sass 3.2.7, sass-rails 3.2.6, bootstrap-sass 2.3.1.0 and it still doesn't like the 5%.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment