Sentiment Analysis on Twitter
Switch branches/tags
Nothing to show
Clone or download
mayank93 Updated README
Updated README to contain more information about project
and files used to run project

Added ./INSTALL which contains commands to install the
prerequisite libraries for "ubuntu 14.04"

Signed-off-by: mayank93 <mayankrocks.1993@gmail.com>
Latest commit f095c6c Dec 12, 2015
Permalink
Failed to load latest commit information.
docs final Apr 17, 2014
front-end Updated README Dec 12, 2015
phrase-level-analysis updated AFINN-111.txt Mar 4, 2015
sentence-level-analysis Updated README Dec 12, 2015
.gitignore Added .gitignore file Dec 12, 2015
INSTALL Updated README Dec 12, 2015
README Updated README Dec 12, 2015

README

Slides available at: http://www.slideshare.net/dalmiaayushi/sentiment-analysis-in-twitter
Video available at: https://www.youtube.com/watch?v=CuAyE9NISzo

This project aims sentiment analysis at two levels:

Sub Task A: Sentiment Analysis of the tweet considering sub phrases
Sub Task B: Sentiment Analysis of the tweet as a whole

Prerequisites:

 1) Python 2.6 or higher
 2) Java
 3) NLTK 2.0     http://www.nltk.org
 4) NumPy        http://numpy.scipy.org
 5) SentiWordNet http://sentiwordnet.isti.cnr.it
 6) Sentiment_classifier 0.5 https://pypi.python.org/pypi/sentiment_classifier
 7) LIBSVM :https://github.com/cjlin1/libsvm
 
"./INSTALL" contains commands to install the  Prerequisite Libraries for ubuntu 14.04.

Look into the ReadMe files of the respective folder to learn more