Doesn't work in R15B #4

Closed
lpgauth opened this Issue Jan 27, 2012 · 1 comment

Comments

Projects
None yet
2 participants

lpgauth commented Jan 27, 2012

=INFO REPORT==== 27-Jan-2012::14:24:16 ===
application: cecho
exited: {{driver_error,"Driver compiled with incorrect version of erl_driver.h"},
         {cecho,start,[normal,[]]}}
type: temporary

From the R15B README:

OTP-9795  == otp erts ==

The driver interface has been changed to enable 64-bit aware
drivers. Most importantly the return types for ErlDrvEntry
callbacks 'call' and 'control' has ben enlarged which require
drivers to be changed or they will cause emulator crashes.
See

Rewrites for 64-bit driver interface in the driver manual.

Due to this driver version management is now mandatory. A
driver that is not written with version management or a
driver that was compiled with the wrong major version will be
not be loaded by the emulator.
Owner

mazenharake commented Feb 26, 2012

Thanks. Now fixed in 7dd32be

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment