Skip to content
Permalink
Browse files

Upgrade to Ruby 2.5

  • Loading branch information
dkubb committed Nov 6, 2018
1 parent 001c4ae commit 41e265391ba1acd23055663738d411d42bc6c520
Showing with 7 additions and 13 deletions.
  1. +3 −9 circle.yml → .circleci/config.yml
  2. +1 −1 .rubocop.yml
  3. +1 −1 lib/mutant/expression/namespace.rb
  4. +1 −1 lib/mutant/warning_filter.rb
  5. +1 −1 mutant.gemspec
@@ -4,20 +4,14 @@ defaults: &defaults
- checkout
- run: bundle install
- run: bundle exec rake ci

version: 2
jobs:
ruby_2_3:
ruby_2_5:
<<: *defaults
docker:
- image: circleci/ruby:2.3.4
ruby_2_4:
<<: *defaults
docker:
- image: circleci/ruby:2.4.1
- image: circleci/ruby:2.5.3
workflows:
version: 2
test:
jobs:
- ruby_2_3
- ruby_2_4
- ruby_2_5
@@ -4,4 +4,4 @@ AllCops:
- 'test_app/**/*'
- 'tmp/**/*'
- 'vendor/**/*'
TargetRubyVersion: 2.3
TargetRubyVersion: 2.5
@@ -44,7 +44,7 @@ def matcher
#
# @return [Integer]
def match_length(expression)
if @recursion_pattern =~ expression.syntax
if @recursion_pattern.match?(expression.syntax)
scope_name.length
else
0
@@ -36,7 +36,7 @@ def initialize(target)
#
# @return [self]
def write(message)
if WARNING_PATTERN =~ message
if WARNING_PATTERN.match?(message)
warnings << message
else
target.write(message)
@@ -21,7 +21,7 @@ Gem::Specification.new do |gem|
gem.extra_rdoc_files = %w[LICENSE]
gem.executables = %w[mutant]

gem.required_ruby_version = '>= 2.3'
gem.required_ruby_version = '>= 2.5'

gem.add_runtime_dependency('abstract_type', '~> 0.0.7')
gem.add_runtime_dependency('adamantium', '~> 0.2.0')

0 comments on commit 41e2653

Please sign in to comment.
You can’t perform that action at this time.