Permalink
Browse files

upgrade to rails 3.1.0.rc4, remove call to deprecated method

  • Loading branch information...
earnold committed Jul 23, 2011
1 parent 2a960db commit 18be329e1303da238ffa0ac9cbf6273621645873
Showing with 4 additions and 4 deletions.
  1. +1 −1 Gemfile
  2. +1 −1 lib/seed-fu/seeder.rb
  3. +2 −2 seed-fu.gemspec
View
@@ -1,5 +1,5 @@
source 'http://rubygems.org'
-gem 'rails', :git => "https://github.com/rails/rails.git"
+gem 'rails', "~> 3.1.0.rc4"
gem "sqlite3-ruby", "~> 1.3.1", :require => 'sqlite3'
gem "arel", :git => "git://github.com/rails/arel.git"
gemspec
View
@@ -64,7 +64,7 @@ def seed_record(data)
puts " - #{@model_class} #{data.inspect}" unless @options[:quiet]
- record.send(:attributes=, data, false)
+ record.send(:assign_attributes, data, :without_protection => true)
record.save(:validate => false) || raise(ActiveRecord::RecordNotSaved)
record
end
View
@@ -14,8 +14,8 @@ Gem::Specification.new do |s|
s.summary = "Easily manage seed data in your Active Record application"
s.description = "Seed Fu is an attempt to once and for all solve the problem of inserting and maintaining seed data in a database. It uses a variety of techniques gathered from various places around the web and combines them to create what is hopefully the most robust seed data system around."
- s.add_dependency "activerecord", "~> 3.1.0.beta"
- s.add_dependency "activesupport", "~> 3.1.0.beta"
+ s.add_dependency "activerecord", "~> 3.1.0.rc4"
+ s.add_dependency "activesupport", "~> 3.1.0.rc4"
s.add_development_dependency "rspec", "~> 2.0"
s.add_development_dependency "pg"

0 comments on commit 18be329

Please sign in to comment.