Permalink
Browse files

Update docs

  • Loading branch information...
jonleighton committed Oct 4, 2011
1 parent 900bbba commit 8d990c1ceb87c8a2ed3a429e4bc3f4f5dbaecd6b
Showing with 16 additions and 9 deletions.
  1. +9 −0 CHANGELOG.md
  2. +7 −9 README.md
View
@@ -1,3 +1,12 @@
+Version 2.1.0
+-------------
+
+Features:
+
+* Deprecations removed
+
+* Rails 3.1 support added, Rails 3.0 support removed (please use 2.0.X line with 3.0)
+
Version 2.0.1
-------------
View
@@ -6,7 +6,7 @@ Seed Fu is an attempt to once and for all solve the problem of inserting and mai
Warning: API Changes
--------------------
-Version 2.0.0 of Seed Fu introduces API changes. `Seed::Writer` has been completely overhauled and will require you to update your scripts. Some other deprecations have been introduced, but the methods will not be removed until version 2.1.0. Please see the [CHANGELOG](CHANGELOG.md) for details.
+Version 2.0.0 of Seed Fu introduced API changes. `Seed::Writer` was been completely overhauled and will require you to update your scripts. Some other deprecations were introduced, and support is fully removed in version 2.1.0. Please see the [CHANGELOG](CHANGELOG.md) for details.
The API documentation is available in full at [http://rubydoc.info/github/mbleigh/seed-fu/master/frames](http://rubydoc.info/github/mbleigh/seed-fu/master/frames).
@@ -39,21 +39,19 @@ Basic Example
Installation
------------
-### Rails 3
+### Rails 3.1
-Just add `gem 'seed-fu'` to your `Gemfile`
-
-### Active Record 3
+Just add `gem 'seed-fu', '~> 2.1.0'` to your `Gemfile`
Seed Fu depends on Active Record, but doesn't have to be used with a full Rails app. Simply load and require the `seed-fu` gem and you're set.
-### Rails 2.3
+### Rails 3.0
-The current version is not backwards compatible with Rails 2.3. Please use Seed Fu [version 1.2.3](https://github.com/mbleigh/seed-fu/tree/v1.2.3).
+The current version is not backwards compatible with Rails 3.0. Please use `gem 'seed-fu', '~> 2.0.0'`.
-### Rails 3.1 (beta)
+### Rails 2.3
-As above, but install the gem which has '.rails31' prepended to its version string. For example, instead of using seed-fu version 2.0.1, use seed-fu version 2.0.1.rails31.
+The current version is not backwards compatible with Rails 2.3. Please use `gem 'seed-fu', '~> 1.2.0'`.
Constraints
-----------

0 comments on commit 8d990c1

Please sign in to comment.