Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Add browserify compatibility #629

Merged
merged 1 commit into from

2 participants

@alexstrat

Hi,

These 3 little lines make d3 compatible with browserify and thus allow developers like me to easily include d3 – or any browserify-compatible module requiring d3 (like cubism.. :D) – in their browserify bundles. Great !

Please merge if OK !

@mbostock mbostock merged commit 637896b into from
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on May 1, 2012
  1. @alexstrat
This page is out of date. Refresh to see the latest.
Showing with 3 additions and 0 deletions.
  1. +2 −0  index-browserify.js
  2. +1 −0  package.json
View
2  index-browserify.js
@@ -0,0 +1,2 @@
+require("./d3.v2");
+module.exports = d3;
View
1  package.json
@@ -20,6 +20,7 @@
"url": "http://github.com/mbostock/d3.git"
},
"main": "index.js",
+ "browserify" : "index-browserify.js",
"dependencies": {
"jsdom": "0.2.14",
"sizzle": "1.1.x"
Something went wrong with that request. Please try again.