This repository has been archived by the owner. It is now read-only.

Warning messages since v13.0 #2023

Closed
Marc66 opened this Issue Jun 25, 2017 · 4 comments

Comments

3 participants
@Marc66

Marc66 commented Jun 25, 2017

I installed version 13.0 this morning and processed a mpeg ts from a TV recording as I normally do and got the following warnings when I loaded the file. I don't have these warnings when I do the same in version 12.0. Running OSX 10.11.6 in French language

The TS file had 1 video and 2 audio streams and no special or accented characters in its name

Could not initialize the iconv library for the conversion from ISO6937 to UTF-8. Some strings will not be converted to UTF-8 and the resulting Matroska file might not comply with the Matroska specs (error: 22, Invalid argument).
Could not initialize the iconv library for the conversion from UTF-8 to ISO6937. Some strings cannot be converted from UTF-8 and might be displayed incorrectly (error: 22, Invalid argument).
Could not initialize the iconv library for the conversion from ISO6937 to UTF-8. Some strings will not be converted to UTF-8 and the resulting Matroska file might not comply with the Matroska specs (error: 22, Invalid argument).
Could not initialize the iconv library for the conversion from UTF-8 to ISO6937. Some strings cannot be converted from UTF-8 and might be displayed incorrectly (error: 22, Invalid argument).

@mbunkus

This comment has been minimized.

Show comment
Hide comment
@mbunkus

mbunkus Jun 25, 2017

Owner

I'll fix that for the next release. You can ignore those warnings until then as they don't affect the resulting file, or keep using v12.

Owner

mbunkus commented Jun 25, 2017

I'll fix that for the next release. You can ignore those warnings until then as they don't affect the resulting file, or keep using v12.

@Marc66

This comment has been minimized.

Show comment
Hide comment
@Marc66

Marc66 Jun 25, 2017

Thank you mbunkus

Marc66 commented Jun 25, 2017

Thank you mbunkus

@welwood08

This comment has been minimized.

Show comment
Hide comment
@welwood08

welwood08 Jul 22, 2017

FYI, I also see these warnings on Windows 8.1 so it's not specific to macOS.

welwood08 commented Jul 22, 2017

FYI, I also see these warnings on Windows 8.1 so it's not specific to macOS.

@mbunkus

This comment has been minimized.

Show comment
Hide comment
@mbunkus

mbunkus Jul 23, 2017

Owner

@welwood08 The workaround (it's not a fix) I've implemented should work on all operating systems where that encoding isn't supported.

Owner

mbunkus commented Jul 23, 2017

@welwood08 The workaround (it's not a fix) I've implemented should work on all operating systems where that encoding isn't supported.

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.