Permalink
Browse files

A patch is required for loudmouth configure script to detect gnutls (by

using pkg-config instead of libgnutls-config).
The patch was collected from the gentoo ebuild, which was borrowed from
Mandriva.
  • Loading branch information...
mcabber committed Oct 10, 2009
1 parent 632ac1c commit 5096e15d05b2ac1dc295bf7af6011f7826504a69
Showing with 2 additions and 1 deletion.
  1. +2 −1 configure.ac
View
@@ -172,8 +172,9 @@ AC_ARG_WITH(openssl-libs,
enable_ssl=no
if test "x$ac_ssl" = "xgnutls"; then
dnl Look for GnuTLS
- AM_PATH_LM_LIBGNUTLS($GNUTLS_REQUIRED, have_libgnutls=yes, have_libgnutls=no)
+ PKG_CHECK_EXISTS([gnutls >= $GNUTLS_REQUIRED], have_libgnutls=yes, have_libgnutls=no)
if test "x$have_libgnutls" = "xyes"; then
+ PKG_CHECK_MODULES(LIBGNUTLS, [gnutls >= $GNUTLS_REQUIRED])
CFLAGS="$CFLAGS $LIBGNUTLS_CFLAGS"
LIBS="$LIBS $LIBGNUTLS_LIBS"
AC_DEFINE(HAVE_GNUTLS, 1, [whether to use GnuTSL support.])

0 comments on commit 5096e15

Please sign in to comment.