Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Branch: master
Commits on Oct 3, 2009
  1. version bump and changelog

    Andre Lewis authored
Commits on Sep 29, 2009
  1. @brennandunn

    Modify README

    brennandunn authored
  2. @brennandunn
  3. @brennandunn

    Remove SQLite

    brennandunn authored
  4. @brennandunn

    Added SQL Server support

    brennandunn authored
  5. @brennandunn

    Added concept of database adapter. Ported mysql/postgresql conditiona…

    brennandunn authored
    …l code to their own adapter.
  6. @brennandunn
  7. @brennandunn
  8. @brennandunn

    Overhaul the test suite to be independent of a Rails project, along w…

    brennandunn authored
    …ith doing some general cleanup. Controller tests are failing now that I'm using ActionController::TestCase.
Commits on Sep 27, 2009
  1. doc updates only

    Andre Lewis authored
  2. Merge branch 'master' of git://github.com/monde/geokit-rails into mon…

    Andre Lewis authored
    …de/master
Commits on Sep 23, 2009
  1. fixed timeout to work with gem v1.5.0. upgrade your geokit gem if it'…

    Andre Lewis authored
    …s lower than that
Commits on Sep 7, 2009
  1. @monde
Commits on Jun 9, 2009
  1. README update, history and version bump

    Andre Lewis authored
Commits on Jun 3, 2009
  1. @josevalim
  2. @josevalim

    Added support to hashes in :through. So you can do: acts_as_mappable …

    josevalim authored
    …:through => { :state => :country }.
Commits on May 22, 2009
  1. updated history and version

    Andre Lewis authored
  2. Merge branch 'master' of git://github.com/dreamcat4/geokit-rails into…

    Andre Lewis authored
    … dreamcat4/master
  3. @dreamcat4
  4. @dreamcat4
  5. @dreamcat4
  6. Merge branch 'master' of git://github.com/dreamcat4/geokit-rails into…

    Andre Lewis authored
    … dreamcat4/master
Commits on May 20, 2009
  1. @dreamcat4

    Improvement: Remove 2nd parameter from MultiGeocoder (not needed)

    dreamcat4 authored
    This change requires an update of the geokit-gem also.
Commits on May 18, 2009
  1. @dreamcat4
  2. rolling back dreamcat's changes

    Andre Lewis authored
Commits on May 13, 2009
  1. @dreamcat4 @andre

    Support for multiple ip geocoders. Requires an update to the Geokit G…

    dreamcat4 authored andre committed
    …em also.
    
    This feature depend on the following external dependancy, first commited as:
    pull url = git@github.com:dreamcat4/geokit-gem.git
    4f1c20455d3d7cf3dabe17bc492012a19d7aa000 Support multiple ip geocoders, including new setting for ip_provider_order
    
    However the changes may have been published as a different commit. To be sure:
    If your geokit gem is up to date (and greater than 1.3.0), then it may include the following line:
    
    $GEOKIT_GEMDIR/lib/geokit/geocoders.rb:73:
    +    @@ip_provider_order = [:geo_plugin,:ip]
    
    Signed-off-by: Andre Lewis <andre.lewis@gmail.com>
  2. @dreamcat4 @andre

    Support move to remove Multi IP Geocoder class

    dreamcat4 authored andre committed
    Signed-off-by: Andre Lewis <andre.lewis@gmail.com>
  3. @dreamcat4 @andre

    Plugin Configuration for Multi-ip Geocoders, and MaxMind City.

    dreamcat4 authored andre committed
    Signed-off-by: Andre Lewis <andre.lewis@gmail.com>
  4. @glennpow @andre

    Fixing options for non-geokit finds

    glennpow authored andre committed
    Signed-off-by: Andre Lewis <andre.lewis@gmail.com>
  5. @glennpow @andre

    Now checks if either :origin OR :bounds is passed, and proceeds with …

    glennpow authored andre committed
    …geokit query if this is true.
    
    Signed-off-by: Andre Lewis <andre.lewis@gmail.com>
  6. @josevalim @andre

    Remove augment_conditions since we have a method that does the same i…

    josevalim authored andre committed
    …n Rails since 2.1.
    
    Signed-off-by: Andre Lewis <andre.lewis@gmail.com>
  7. @josevalim @andre

    Raises a helpful error if someone uses through but the association do…

    josevalim authored andre committed
    …es not exists or was not defined yet
    
    Signed-off-by: Andre Lewis <andre.lewis@gmail.com>
Commits on May 2, 2009
  1. @dreamcat4

    Support for multiple ip geocoders. Requires an update to the Geokit G…

    dreamcat4 authored
    …em also.
    
    This feature depend on the following external dependancy, first commited as:
    pull url = git@github.com:dreamcat4/geokit-gem.git
    4f1c20455d3d7cf3dabe17bc492012a19d7aa000 Support multiple ip geocoders, including new setting for ip_provider_order
    
    However the changes may have been published as a different commit. To be sure:
    If your geokit gem is up to date (and greater than 1.3.0), then it may include the following line:
    
    $GEOKIT_GEMDIR/lib/geokit/geocoders.rb:73:
    +    @@ip_provider_order = [:geo_plugin,:ip]
  2. @dreamcat4

    Support for multiple ip geocoders. Requires an update to the Geokit G…

    dreamcat4 authored
    …em also.
    
    This feature depend on the following external dependancy, first commited as:
    pull url = git@github.com:dreamcat4/geokit-gem.git
    4f1c20455d3d7cf3dabe17bc492012a19d7aa000 Support multiple ip geocoders, including new setting for ip_provider_order
    
    However the changes may have been published as a different commit. To be sure:
    If your geokit gem is up to date (and greater than 1.3.0), then it may include the following line:
    
    $GEOKIT_GEMDIR/lib/geokit/geocoders.rb:73:
    +    @@ip_provider_order = [:geo_plugin,:ip]
Something went wrong with that request. Please try again.