Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
branch: master
Fetching contributors…

Cannot retrieve contributors at this time

file 57 lines (48 sloc) 1.159 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57
require File.expand_path("../padrino-core/lib/padrino-core/version.rb", __FILE__)

source :rubygems

group :core do
  gem "sinatra", ">= 1.0.0"
  gem "http_router", ">= 0.2.3"
  gem "thor", ">= 0.13.0"
  # If you want try our test on AS edge.
  # $ AS=edge bundle install
  # $ AS=edge rake test
  if ENV['AS'] == "edge"
    puts "Using ActiveSupport 3.0.0.beta4"
    gem "activesupport", ">= 3.0.0.beta4", :require => nil
    gem "tzinfo"
  else
    gem "activesupport", ">= 2.3.8", :require => nil
  end
end

group :cache do
  gem "sinatra", ">= 0.9.2"
end

group :gen do
  gem "bundler", ">= 0.9.7"
end

group :helpers do
  gem "i18n", ">=0.4.1"
end

group :mailer do
  gem "mail", ">= 2.2.0"
  gem "tlsmail" if RUBY_VERSION == "1.8.6"
end

group :other do
  gem "builder", ">= 2.1.2"
end

group :db do
  gem "dm-core", ">= 1.0"
  gem "dm-migrations", ">= 1.0"
  gem "dm-validations", ">= 1.0"
  gem "dm-aggregates", ">= 1.0"
  gem "dm-sqlite-adapter", ">= 1.0"
end

group :development do
  gem "rake", ">= 0.8.7"
  gem "mocha", ">= 0.9.8"
  gem "rack-test", ">= 0.5.0"
  gem "webrat", ">= 0.5.1"
  gem "haml", ">= 2.2.22"
  gem "shoulda", ">= 2.10.3"
end
Something went wrong with that request. Please try again.