Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Fixed browserify step.

  • Loading branch information...
commit ef223e9c6d1194b15e082cbfbceb04c7dec69ace 1 parent ec5a1cb
@mcollina authored
View
22 Makefile
@@ -1,22 +0,0 @@
-test:
- ./node_modules/.bin/mocha --recursive test
-
-bail:
- ./node_modules/.bin/mocha --recursive --bail --reporter spec test
-
-ci:
- ./node_modules/.bin/mocha --recursive --watch test
-
-jshint:
- find lib -name "*.js" -print0 | xargs -0 ./node_modules/.bin/jshint
- find test -name "*.js" -print0 | xargs -0 ./node_modules/.bin/jshint
-
-browserify:
- rm -rf build
- mkdir build
- ./node_modules/.bin/browserify -s levelgraph -r level-js -r levelup ./lib/levelgraph.js > build/levelgraph.js
- ./node_modules/.bin/uglifyjs build/levelgraph.js > build/levelgraph.min.js
- gzip -c build/levelgraph.min.js > build/levelgraph.min.js.gz
- du -h build/*
-
-.PHONY: test
View
8 browserify.sh
@@ -0,0 +1,8 @@
+#! /bin/sh
+
+rm -rf build
+mkdir build
+./node_modules/.bin/browserify -s levelgraph -r level-js -r levelup ./lib/levelgraph.js > build/levelgraph.js
+./node_modules/.bin/uglifyjs build/levelgraph.js > build/levelgraph.min.js
+gzip -c build/levelgraph.min.js > build/levelgraph.min.js.gz
+du -h build/*
View
20,445 build/levelgraph.js
11,119 additions, 9,326 deletions not shown
View
17 build/levelgraph.min.js
9 additions, 8 deletions not shown
View
9 package.json
@@ -4,7 +4,9 @@
"description": "A graph database for Node.js and the browser built on top of LevelUp",
"main": "lib/levelgraph.js",
"scripts": {
- "test": "make bail",
+ "test": "mocha --recursive --bail --reporter spec test",
+ "testling": "testling -u",
+ "ci": "mocha --recursive --bail --watch test",
"jshint-lib": "jshint lib/*.js",
"jshint-test": "jshint test/*.js"
},
@@ -41,9 +43,10 @@
"jshint": "~2.3.0",
"level-test": "~1.5.2",
"uglify-js": "~2.3.6",
- "browserify": "~2.29.1",
+ "browserify": "~2.35.4",
"levelup": "~0.18.0",
- "pre-commit": "0.0.4"
+ "pre-commit": "0.0.4",
+ "testling": "~1.5.3"
},
"dependencies": {
"xtend": "~2.1.1",
Please sign in to comment.
Something went wrong with that request. Please try again.