Node 0.10 breaking changes break utilities (and jake) #6

Closed
billti opened this Issue Mar 10, 2013 · 1 comment

Projects

None yet

2 participants

@billti
billti commented Mar 10, 2013

As per https://github.com/joyent/node/wiki/Api-changes-between-v0.8-and-v0.10 , path.resolve & path.join will now throw an error on non-string input (previously they ignored it).

I was just trying to build TypeScript (which uses jake) with the latest Node v0.10 and hit issues. mkDirP in ./lib/file.js doesn't initialize currPath, so the first call to path.join with it (https://github.com/mde/utilities/blob/master/lib/file.js#L285) throws an exception now.

Simply changing the currPath declaration 10 lines earlier to ' currPath = "" ' (an empty string) fixed the issue for me. Not sure any other areas you might get bitten by this!

Owner
mde commented Mar 10, 2013

Fixed in 0605188, pushed to NPM in v0.0.20.

@mde mde closed this Mar 10, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment