Permalink
Browse files

Fixed eclipse tooling problem. Projects are now referenced correctly.

Upgraded libraries (Hibernate 4.1.5 and jackson 1.9.9)
  • Loading branch information...
1 parent 284475a commit b279a1089988db284386dc5074a4c22a47d2197f @mdeinum committed Aug 1, 2012
Showing with 14 additions and 55 deletions.
  1. +0 −7 bookstore-shared/build.gradle
  2. +0 −7 bookstore-web-resources/build.gradle
  3. +13 −41 build.gradle
  4. +1 −0 chapter2-bookstore/build.gradle
@@ -1,7 +0,0 @@
-eclipse {
- project {
- natures 'org.eclipse.wst.common.project.facet.core.nature', 'org.eclipse.wst.common.modulecore.ModuleCoreNature', 'org.eclipse.jem.workbench.JavaEMFNature'
- buildCommand 'org.eclipse.wst.common.project.facet.core.builder'
- buildCommand 'org.eclipse.wst.validation.validationbuilder'
- }
-}
@@ -1,7 +0,0 @@
-eclipse {
- project {
- natures 'org.eclipse.wst.common.project.facet.core.nature', 'org.eclipse.wst.common.modulecore.ModuleCoreNature', 'org.eclipse.jem.workbench.JavaEMFNature'
- buildCommand 'org.eclipse.wst.common.project.facet.core.builder'
- buildCommand 'org.eclipse.wst.validation.validationbuilder'
- }
-}
View
@@ -4,9 +4,9 @@ ext.springVersion='3.1.2.RELEASE'
ext.tilesVersion='2.2.2'
ext.springSecurityVersion='3.1.1.RELEASE'
ext.springSwfVersion='2.3.1.RELEASE'
-ext.hibernateVersion='4.1.4.Final'
+ext.hibernateVersion='4.1.5.SP1'
ext.hibernateValidatorVersion='4.3.0.Final'
-ext.ehCacheVersion='2.5.2'
+ext.ehCacheVersion='2.5.3'
ext.tomcatVersion = '7.0.29'
ext.cargoVersion = '1.1.3'
@@ -22,16 +22,13 @@ buildscript {
}
dependencies {
- classpath 'bmuschko:gradle-tomcat-plugin:0.9.2'
- classpath 'bmuschko:gradle-cargo-plugin:0.5.2'
+ classpath 'bmuschko:gradle-tomcat-plugin:0.9.3'
+ classpath 'bmuschko:gradle-cargo-plugin:0.5.4'
}
}
allprojects {
- apply plugin: 'eclipse'
- apply plugin: 'idea'
-
description='Bookstore Sample Application'
group = 'com.apress.prospringmvc'
@@ -47,10 +44,6 @@ allprojects {
mavenRepo url: 'http://download.java.net/maven/glassfish/org/glassfish/'
}
- eclipse {
- project.natures "org.springframework.ide.eclipse.core.springnature"
- }
-
tasks.withType(Compile) {
options.compilerArgs << "-g"
}
@@ -60,7 +53,6 @@ configure(webProjects) {
apply plugin: 'war'
apply plugin: 'jetty'
apply plugin: 'tomcat'
- apply plugin: 'eclipse-wtp'
apply plugin: 'cargo'
dependencies() {
@@ -112,38 +104,17 @@ configure(webProjects) {
test {
exclude '**/*FrontendTest.*'
}
-
- eclipse {
- classpath {
- file {
- withXml {
- xml -> xml.asNode().classpathentry.findAll{
- it.@path == '/bookstore-shared' || it.@path == '/bookstore-web-resources'
- }.each{
- it.appendNode('attributes').appendNode('attribute',
- [
- name: 'org.eclipse.jst.component.dependency',
- value: '/WEB-INF/lib'
- ])
- }
- }
- }
- }
- }
-
+
}
subprojects() {
apply plugin: 'java'
+ apply plugin: 'eclipse-wtp'
+ apply plugin: 'idea'
sourceCompatibility=1.6
targetCompatibility=1.6
-
- configurations {
- provided
- compile.extendsFrom provided
- }
dependencies() {
compile "org.springframework:spring-orm:$springVersion"
@@ -155,7 +126,7 @@ subprojects() {
compile 'ch.qos.logback:logback-classic:1.0.6'
compile 'org.apache.commons:commons-lang3:3.0.1'
compile 'com.thoughtworks.xstream:xstream:1.4.2'
- compile 'com.h2database:h2:1.3.167'
+ compile 'com.h2database:h2:1.3.168'
compile 'cglib:cglib-nodep:2.2.2'
compile 'org.aspectj:aspectjrt:1.6.12'
compile 'org.aspectj:aspectjweaver:1.6.12'
@@ -168,17 +139,18 @@ subprojects() {
compile 'com.lowagie:itext:2.1.7'
compile 'net.sourceforge.jexcelapi:jxl:2.6.12'
- compile 'org.codehaus.jackson:jackson-mapper-asl:1.9.8'
+ compile 'org.codehaus.jackson:jackson-mapper-asl:1.9.9'
compile 'commons-codec:commons-codec:1.6'
compile 'joda-time:joda-time:2.0'
testCompile 'junit:junit:4.9'
testCompile "org.springframework:spring-test:$springVersion"
}
-}
-configure(subprojects.findAll {it.name == 'chapter2-samples'}) {
+
+ eclipse {
+ project.natures "org.springframework.ide.eclipse.core.springnature"
+ }
- dependencies() { compile "org.springframework:spring-test:$springVersion" }
}
task wrapper(type: Wrapper) { gradleVersion = '1.0' }
@@ -0,0 +1 @@
+dependencies() { compile "org.springframework:spring-test:$springVersion" }

0 comments on commit b279a10

Please sign in to comment.