Permalink
Browse files

merging changes

  • Loading branch information...
1 parent ef4aa9d commit b67aed3ddad5085332debf1817126b975e4d8622 @mdeiters committed Jun 6, 2010
Showing with 9 additions and 15 deletions.
  1. +0 −1 Rakefile
  2. +1 −1 config/warble.rb
  3. +8 −13 neo4jr-social.gemspec
View
1 Rakefile
@@ -54,7 +54,6 @@ task :warify do
commands = ['rm -rf tmp']
commands << 'warble'
commands << 'rm -f jetty-runtime/webapps/neo4jr-social.war'
-# commands << "mv neo4jr-social-#{version}.war jetty-runtime/webapps/neo4jr-social.war"
commands << "mv neo4jr-social.war jetty-runtime/webapps/neo4jr-social.war"
commands.each do |command|
STDERR.puts("Executing: #{command}")
View
2 config/warble.rb
@@ -5,7 +5,7 @@
config.gems << Gem::Dependency.new("sinatra", ">= 1.0")
config.gems << Gem::Dependency.new("json-jruby", ">= 1.4.1")
- config.gems << Gem::Dependency.new("neo4jr-simple", ">= 0.2.1")
+ config.gems << Gem::Dependency.new("neo4jr-simple", ">= 0.2.2")
config.gem_dependencies = true
config.webxml.booter = :rack
View
21 neo4jr-social.gemspec
@@ -9,9 +9,8 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Matthew Deiters"]
- s.date = %q{2010-05-03}
+ s.date = %q{2010-06-06}
s.default_executable = %q{start-neo4jr-social}
- s.description = %q{A self-containted lightweight REST interface to Neo4j using JRuby }
s.email = %q{matthew_deiters@mckinsey.com}
s.executables = ["start-neo4jr-social"]
s.extra_rdoc_files = [
@@ -42,7 +41,6 @@ Gem::Specification.new do |s|
"jetty-runtime/lib/jsp-2.1/jsp-api-2.1.jar",
"jetty-runtime/lib/servlet-api-2.5-6.1.3.jar",
"jetty-runtime/start.jar",
- "jetty-runtime/webapps/neo4jr-social.war",
"lib/neo4jr-social.rb",
"lib/neo4jr-social/format_handler.rb",
"lib/neo4jr-social/json_printer.rb",
@@ -59,7 +57,7 @@ Gem::Specification.new do |s|
s.homepage = %q{http://github.com/mdeiters/neo4jr-social}
s.rdoc_options = ["--charset=UTF-8"]
s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.5}
+ s.rubygems_version = %q{1.3.6}
s.summary = %q{A self-containted and lightweight REST interface to Neo4j using JRuby.}
s.test_files = [
"spec/format_handler_spec.rb",
@@ -77,25 +75,22 @@ Gem::Specification.new do |s|
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
s.add_development_dependency(%q<rspec>, [">= 1.2.9"])
s.add_development_dependency(%q<rest-client>, [">= 0"])
- s.add_development_dependency(%q<rack-test>, [">= 0"])
- s.add_runtime_dependency(%q<neo4jr-simple>, ["= 0.2.1"])
+ s.add_runtime_dependency(%q<neo4jr-simple>, ["= 0.2.2"])
s.add_runtime_dependency(%q<sinatra>, [">= 1.0"])
- s.add_runtime_dependency(%q<json-jruby>, [">= 0"])
+ s.add_runtime_dependency(%q<json-jruby>, [">= 1.4.1"])
else
s.add_dependency(%q<rspec>, [">= 1.2.9"])
s.add_dependency(%q<rest-client>, [">= 0"])
- s.add_dependency(%q<rack-test>, [">= 0"])
- s.add_dependency(%q<neo4jr-simple>, ["= 0.2.1"])
+ s.add_dependency(%q<neo4jr-simple>, ["= 0.2.2"])
s.add_dependency(%q<sinatra>, [">= 1.0"])
- s.add_dependency(%q<json-jruby>, [">= 0"])
+ s.add_dependency(%q<json-jruby>, [">= 1.4.1"])
end
else
s.add_dependency(%q<rspec>, [">= 1.2.9"])
s.add_dependency(%q<rest-client>, [">= 0"])
- s.add_dependency(%q<rack-test>, [">= 0"])
- s.add_dependency(%q<neo4jr-simple>, ["= 0.2.1"])
+ s.add_dependency(%q<neo4jr-simple>, ["= 0.2.2"])
s.add_dependency(%q<sinatra>, [">= 1.0"])
- s.add_dependency(%q<json-jruby>, [">= 0"])
+ s.add_dependency(%q<json-jruby>, [">= 1.4.1"])
end
end

0 comments on commit b67aed3

Please sign in to comment.