Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update nodejs compat for javascript.function.rest_parameters #1744

Merged
merged 2 commits into from Apr 11, 2018

Conversation

Projects
None yet
2 participants
@demurgos
Copy link
Contributor

demurgos commented Apr 6, 2018

This commit documents Node.js compatibility for function rest
parameters. This mainly depends on V8 but I tracked the relevant Node
versions, commits and PRs.

Note that I used 4 for the version of the flag addition because 3
corresponds to the io.js fork and is not recognized as a valid nodejs
version by the linter.

Flagged support (io.js 3.0.0, V8 4.4):

Stable support (Node.js 6.0.0, V8 4.7):

Flag removal (Node.js 6.0.0, V8 4.9):

Update nodejs compat for javascript.function.rest_parameters
This commit documents Node.js compatibility for function rest
parameters. This mainly depends on V8 but I tracked the relevant Node
versions, commits and PRs.

Note that I used `4` for the version of the flag addition because `3`
corresponds to the io.js fork and is not recognized as a valid `nodejs`
version by the linter.

Flagged support (io.js 3.0.0, V8 4.4):

- [Node.js changelog entry for version 3.0.0](https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_IOJS.md#2015-08-04-version-300-rvagg)
- [Pull Request](nodejs/node#2022)
- [Commit, with anchor to relevant line](nodejs/node@70d1f32#diff-b2e04de0d939630d882245c2243e7e47R200)

Stable support (Node.js 6.0.0, V8 4.7):

- [Node.js changelog entry for version 6.0.0](https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V6.md#2016-04-26-version-600-current-jasnell)
- [Pull Request](nodejs/node#4106)
- [Commit, with anchor to relevant line](nodejs/node@8a43a3d#diff-b2e04de0d939630d882245c2243e7e47R217)

Flag removal (Node.js 6.0.0, V8 4.9):
- [Node.js changelog entry for version 6.0.0](https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V6.md#2016-04-26-version-600-current-jasnell)
- [Pull Request](nodejs/node#4722)
- [Commit, with anchor to relevant line](nodejs/node@069e02a#diff-b2e04de0d939630d882245c2243e7e47L221)

@demurgos demurgos referenced this pull request Apr 6, 2018

Merged

Do not use arguments object #3102

0 of 2 tasks complete

@Elchi3 Elchi3 added the data:js 📟 label Apr 6, 2018

@demurgos demurgos referenced this pull request Apr 6, 2018

Closed

Update Node.js versions #1747

@Elchi3

Elchi3 approved these changes Apr 11, 2018

Copy link
Member

Elchi3 left a comment

Thanks for contributing to MDN browser-compat-data and especially for your detailed research when this was exposed in which way.

I removed the notes with the references to the PRs/commits that proof the information, because we do not generally add this kind of info to the data . It is good to have it as (meta) info in this PR, though, so it can be seen when using blame, for example.

Thanks again for your work! 🎉

@Elchi3 Elchi3 merged commit 8292290 into mdn:master Apr 11, 2018

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
@demurgos

This comment has been minimized.

Copy link
Contributor Author

demurgos commented Apr 11, 2018

Thanks for merging it.
Node 4 is reaching EOL so I have a few Node projects (Hexo, Gulp) that are looking into which new features are available to them or not. I'll send more PRs if I find time.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.