Skip to content
Browse files

Fix call to show_lookup_failure for newer Rubygems.

  • Loading branch information...
1 parent fa65c8b commit c13fade48e2a3f647857caa67596de4baaa41af5 @mdub committed Mar 19, 2011
Showing with 2 additions and 2 deletions.
  1. +1 −1 gem_require.gemspec
  2. +1 −1 lib/rubygems/commands/require_command.rb
View
2 gem_require.gemspec
@@ -3,7 +3,7 @@
Gem::Specification.new do |gem|
gem.name = "gem_require"
- gem.version = "0.0.5"
+ gem.version = "0.1.0"
gem.platform = Gem::Platform::RUBY
gem.homepage = "http://github.com/mdub/gem_require"
View
2 lib/rubygems/commands/require_command.rb
@@ -70,7 +70,7 @@ def execute
alert_error "Error installing #{name}:\n\t#{e.message}"
exit_code |= 1
rescue Gem::GemNotFoundException => e
- show_lookup_failure e.name, e.version, e.errors
+ show_lookup_failure e.name, e.version, e.errors, options[:domain]
exit_code |= 2
end
end

0 comments on commit c13fade

Please sign in to comment.
Something went wrong with that request. Please try again.