Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Ruby 1.9 Compatibility #1

Closed
wants to merge 1 commit into
from

Conversation

Projects
None yet
2 participants

Hi there,

I noticed a few tiny errors with 1.9.2p0 that are corrected in this commit.

Dean Strelau Ruby 1.9.2 compatibility.
 - String#each doesn't exist anymore.
 - RubyGems apparently modifies the version string.
0abc2f2
Owner

mdub commented Sep 1, 2010

Hi Dean - thanks for the input.

The s/each/each_line/ change doesn't seem right; the "body" of a Rack response is supposed to respond to #each. I've fixed the examples where I was returning a String a the body, to return an Array instead.

I still haven't quite got the tests passing in 1.9.2 - seeing errors of the form:

rack.input #<StringIO:0x00000102822f50> does not have ASCII-8BIT as its external encoding

dstrelau commented Sep 1, 2010

Ah, you're totally right. I see you've got it straightened out now & have pushed a new version. Thanks!

Owner

mdub commented Sep 1, 2010

No problem. Thanks for prodding me into action.

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment