Permalink
Browse files

Updated node/npm versions; new version check working for npm v1.0.x

  • Loading branch information...
1 parent 91dfd1f commit df06c5f423339aada1b6bc1566e28c3c34219e97 @mdxp committed Jun 4, 2011
Showing with 12 additions and 12 deletions.
  1. +2 −2 nodejs/attributes/default.rb
  2. +8 −8 nodejs/metadata.json
  3. +1 −1 nodejs/metadata.rb
  4. +1 −1 nodejs/recipes/npm.rb
@@ -17,6 +17,6 @@
# limitations under the License.
#
-default.nodejs[:version] = "0.4.4"
+default.nodejs[:version] = "0.4.8"
default.nodejs[:dir] = "/usr/local"
-default.nodejs[:npm] = "0.3.18"
+default.nodejs[:npm] = "1.0.9-1"
View
@@ -1,4 +1,5 @@
{
+ "maintainer_email": "marius@promethost.com",
"groupings": {
},
"attributes": {
@@ -16,19 +17,18 @@
},
"suggestions": {
},
- "conflicting": {
- },
"platforms": {
},
"license": "Apache 2.0",
- "long_description": "= DESCRIPTION:\n\nInstalls Node.JS from source.\n\n= REQUIREMENTS:\n\n== Platform:\n\nTested on Debian Lenny. Should work fine on Ubuntu, Centos, etc.\n\n== Cookbooks:\n\nOpscode cookbooks (http://github.com/opscode/cookbooks/tree/master)\n\n* build-essential\n\n= ATTRIBUTES:\n\n* nodejs[:version] - release version of node to install\n* nodejs[:dir] - location where node will be installed, default /usr/local\n* nodejs[:npm] - version of npm to install\n\n= USAGE:\n\nInclude the nodejs recipe to install node from source on your system:\n\n include_recipe \"nodejs\"\n\nInclude the npm recipe to install npm:\n \n include_recipe \"nodejs::npm\"\n\n= LICENSE and AUTHOR:\n\nAuthor:: Marius Ducea (marius@promethost.com)\n\nCopyright:: 2010, Promet Solutions\n\nLicensed under the Apache License, Version 2.0 (the \"License\");\nyou may not use this file except in compliance with the License.\nYou may obtain a copy of the License at\n\n http://www.apache.org/licenses/LICENSE-2.0\n\nUnless required by applicable law or agreed to in writing, software\ndistributed under the License is distributed on an \"AS IS\" BASIS,\nWITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.\nSee the License for the specific language governing permissions and\nlimitations under the License.\n",
- "version": "0.4.1",
+ "version": "0.5.0",
+ "conflicting": {
+ },
"providing": {
},
- "maintainer": "Promet Solutions",
+ "long_description": "= DESCRIPTION:\n\nInstalls Node.JS from source.\n\n= REQUIREMENTS:\n\n== Platform:\n\nTested on Debian Lenny. Should work fine on Ubuntu, Centos, etc.\n\n== Cookbooks:\n\nOpscode cookbooks (http://github.com/opscode/cookbooks/tree/master)\n\n* build-essential\n\n= ATTRIBUTES:\n\n* nodejs[:version] - release version of node to install\n* nodejs[:dir] - location where node will be installed, default /usr/local\n* nodejs[:npm] - version of npm to install\n\n= USAGE:\n\nInclude the nodejs recipe to install node from source on your system:\n\n include_recipe \"nodejs\"\n\nInclude the npm recipe to install npm:\n \n include_recipe \"nodejs::npm\"\n\n= LICENSE and AUTHOR:\n\nAuthor:: Marius Ducea (marius@promethost.com)\n\nCopyright:: 2010, Promet Solutions\n\nLicensed under the Apache License, Version 2.0 (the \"License\");\nyou may not use this file except in compliance with the License.\nYou may obtain a copy of the License at\n\n http://www.apache.org/licenses/LICENSE-2.0\n\nUnless required by applicable law or agreed to in writing, software\ndistributed under the License is distributed on an \"AS IS\" BASIS,\nWITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.\nSee the License for the specific language governing permissions and\nlimitations under the License.\n",
"name": "nodejs",
- "replacing": {
- },
+ "maintainer": "Promet Solutions",
"description": "Installs/Configures nodejs",
- "maintainer_email": "marius@promethost.com"
+ "replacing": {
+ }
}
View
@@ -3,7 +3,7 @@
license "Apache 2.0"
description "Installs/Configures nodejs"
long_description IO.read(File.join(File.dirname(__FILE__), 'README.rdoc'))
-version "0.4.1"
+version "0.5.0"
recipe "nodejs", "Installs Node.JS from source"
recipe "nodejs::npm", "Installs npm - a package manager for node"
View
@@ -31,6 +31,6 @@
curl -L http://registry.npmjs.org/npm/-/npm-#{node[:nodejs][:npm]}.tgz | tar xzf - --strip-components=1 && \
make uninstall dev
EOH
- not_if {File.exists?("/usr/local/bin/npm@#{node[:nodejs][:npm]}")}
+ not_if "#{node[:nodejs][:dir]}/bin/npm -v 2>&1 | grep '#{node[:nodejs][:npm]}'"
end

0 comments on commit df06c5f

Please sign in to comment.