Skip to content
Browse files

Bumped ironfan version. Also, am versioning in the Gemfile.lock, and …

…commented out vagrant -- it has a confict with chef, dammit
  • Loading branch information...
1 parent 686e905 commit f6a6f274437260a50643e5d6be88b583c8e3d053 Philip (flip) Kromer committed
Showing with 160 additions and 4 deletions.
  1. +0 −1 .gitignore
  2. +5 −3 Gemfile
  3. +155 −0 Gemfile.lock
View
1 .gitignore
@@ -40,7 +40,6 @@ pkg
.rvmrc
.vendor
.bundle
-Gemfile.lock
## PROJECT::SPECIFIC
View
8 Gemfile
@@ -5,10 +5,12 @@ source "http://rubygems.org"
#
gem 'chef', "= 0.10.8"
-gem 'ironfan', "~> 3.1.1"
+gem 'ironfan', "~> 3.1.3"
-gem 'vagrant', "~> 0.9.7"
-gem 'veewee', "~> 0.2.3"
+# # vagrant and chef are being dicks about the version net-ssh should have.
+# # to use the knife vagrant stuff you will have to munge the chef gemspec
+# gem 'vagrant', "~> 0.9.7"
+# gem 'veewee', "~> 0.2.3"
#
# Test drivers
View
155 Gemfile.lock
@@ -0,0 +1,155 @@
+GIT
+ remote: git@github.com:infochimps/guard-chef.git
+ revision: 53f7fba49523bf3b45cd4cac6a18c03ef2c4f210
+ specs:
+ guard-chef (0.0.2)
+ guard (>= 0.2.2)
+
+GEM
+ remote: http://rubygems.org/
+ specs:
+ builder (3.0.0)
+ bunny (0.7.9)
+ chef (0.10.8)
+ bunny (>= 0.6.0)
+ erubis
+ highline
+ json (>= 1.4.4, <= 1.6.1)
+ mixlib-authentication (>= 1.1.0)
+ mixlib-cli (>= 1.1.0)
+ mixlib-config (>= 1.1.2)
+ mixlib-log (>= 1.3.0)
+ moneta
+ net-ssh (~> 2.1.3)
+ net-ssh-multi (~> 1.1.0)
+ ohai (>= 0.6.0)
+ rest-client (>= 1.0.4, < 1.7.0)
+ treetop (~> 1.4.9)
+ uuidtools
+ coderay (1.0.5)
+ cucumber (1.1.9)
+ builder (>= 2.1.2)
+ diff-lcs (>= 1.1.2)
+ gherkin (~> 2.9.0)
+ json (>= 1.4.6)
+ term-ansicolor (>= 1.0.6)
+ diff-lcs (1.1.3)
+ erubis (2.7.0)
+ excon (0.9.6)
+ ffi (1.0.11)
+ fog (1.1.2)
+ builder
+ excon (~> 0.9.0)
+ formatador (~> 0.2.0)
+ mime-types
+ multi_json (~> 1.0.3)
+ net-scp (~> 1.0.4)
+ net-ssh (>= 2.1.3)
+ nokogiri (~> 1.5.0)
+ ruby-hmac
+ formatador (0.2.1)
+ gherkin (2.9.0)
+ json (>= 1.4.6)
+ git (1.2.5)
+ gorillib (0.1.8)
+ json
+ grit (2.4.1)
+ diff-lcs (~> 1.1)
+ mime-types (~> 1.15)
+ guard (1.0.0)
+ ffi (>= 0.5.0)
+ thor (~> 0.14.6)
+ guard-cucumber (0.7.5)
+ cucumber (>= 0.10)
+ guard (>= 0.8.3)
+ guard-process (1.0.2)
+ ffi (~> 1.0.9)
+ guard (>= 0.4.2)
+ spoon (~> 0.0.1)
+ highline (1.6.11)
+ ironfan (3.1.3)
+ chef (~> 0.10.4)
+ fog (~> 1.1.1)
+ formatador (~> 0.2.1)
+ gorillib (~> 0.1.7)
+ jeweler (1.8.3)
+ bundler (~> 1.0)
+ git (>= 1.2.5)
+ rake
+ rdoc
+ json (1.6.1)
+ method_source (0.7.0)
+ mime-types (1.17.2)
+ mixlib-authentication (1.1.4)
+ mixlib-log
+ mixlib-cli (1.2.2)
+ mixlib-config (1.1.2)
+ mixlib-log (1.3.0)
+ moneta (0.6.0)
+ multi_json (1.0.4)
+ net-scp (1.0.4)
+ net-ssh (>= 1.99.1)
+ net-ssh (2.1.4)
+ net-ssh-gateway (1.1.0)
+ net-ssh (>= 1.99.1)
+ net-ssh-multi (1.1)
+ net-ssh (>= 2.1.4)
+ net-ssh-gateway (>= 0.99.0)
+ nokogiri (1.5.0)
+ ohai (0.6.10)
+ mixlib-cli
+ mixlib-config
+ mixlib-log
+ systemu (~> 2.2.0)
+ yajl-ruby
+ polyglot (0.3.3)
+ pry (0.9.8.2)
+ coderay (~> 1.0.5)
+ method_source (~> 0.7)
+ slop (>= 2.4.4, < 3)
+ rake (0.9.2.2)
+ rdoc (3.12)
+ json (~> 1.4)
+ rest-client (1.6.7)
+ mime-types (>= 1.16)
+ rspec (2.8.0)
+ rspec-core (~> 2.8.0)
+ rspec-expectations (~> 2.8.0)
+ rspec-mocks (~> 2.8.0)
+ rspec-core (2.8.0)
+ rspec-expectations (2.8.0)
+ diff-lcs (~> 1.1.2)
+ rspec-mocks (2.8.0)
+ ruby-hmac (0.4.0)
+ ruby_gntp (0.3.4)
+ slop (2.4.4)
+ spoon (0.0.1)
+ systemu (2.2.0)
+ term-ansicolor (1.0.7)
+ thor (0.14.6)
+ treetop (1.4.10)
+ polyglot
+ polyglot (>= 0.3.1)
+ uuidtools (2.1.2)
+ yajl-ruby (1.1.0)
+ yard (0.7.5)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ bundler (~> 1)
+ chef (= 0.10.8)
+ cucumber (~> 1.1)
+ grit
+ guard (~> 1)
+ guard-chef!
+ guard-cucumber
+ guard-process (~> 1)
+ ironfan (~> 3.1.3)
+ jeweler
+ pry
+ rake
+ rspec (~> 2.5)
+ ruby_gntp
+ yard (~> 0.6)

0 comments on commit f6a6f27

Please sign in to comment.
Something went wrong with that request. Please try again.