Permalink
Browse files

[CHEF-1548] add a pessimistic constraint on json

  • Loading branch information...
1 parent 8bd51a2 commit 396f0e50f4fbc98547021ff9f435c4309ae2dfa0 @danielsdeleo danielsdeleo committed Aug 18, 2010
Showing with 4 additions and 4 deletions.
  1. +1 −1 chef-server-api/Rakefile
  2. +1 −1 chef-server-webui/Rakefile
  3. +1 −1 chef/README.rdoc
  4. +1 −1 chef/Rakefile
View
@@ -35,7 +35,7 @@ spec = Gem::Specification.new do |s|
s.add_dependency "mixlib-authentication", '>= 1.1.3'
- s.add_dependency "json", ">= 1.4.4"
+ s.add_dependency "json", ">= 1.4.4", "<= 1.4.6"
s.add_dependency "uuidtools", "~> 2.1.1"
@@ -34,7 +34,7 @@ spec = Gem::Specification.new do |s|
s.add_dependency "merb-haml", "~> 1.1.0"
s.add_dependency "merb-param-protection", "~> 1.1.0"
- s.add_dependency "json", ">= 1.4.4"
+ s.add_dependency "json", ">= 1.4.4", "<= 1.4.6"
%w{thin haml ruby-openid coderay}.each { |g| s.add_dependency g}
View
@@ -47,7 +47,7 @@ Install these via your platform's preferred method; for example apt, yum, ports,
* erubis
* extlib
* highline
-* json (1.4.4)
+* json (1.4.4 - 1.4.6)
* mixlib-authentication
* mixlib-cli
* mixlib-config
View
@@ -50,7 +50,7 @@ spec = Gem::Specification.new do |s|
s.add_dependency "rest-client", ">= 1.0.4", "<= 1.5.1"
s.add_dependency "bunny", ">= 0.6.0"
- s.add_dependency "json", ">= 1.4.4"
+ s.add_dependency "json", ">= 1.4.4", "<= 1.4.6"
%w{erubis extlib moneta highline uuidtools}.each { |gem| s.add_dependency gem }
s.bindir = "bin"

0 comments on commit 396f0e5

Please sign in to comment.