Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
The Grails Web Application Framework

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
bundlor
gradle
grails-bootstrap
grails-core
grails-crud
grails-docs
grails-hibernate
grails-plugin-async
grails-plugin-codecs
grails-plugin-controllers
grails-plugin-converters
grails-plugin-datasource
grails-plugin-domain-class
grails-plugin-filters
grails-plugin-gsp
grails-plugin-i18n
grails-plugin-logging
grails-plugin-mimetypes
grails-plugin-scaffolding
grails-plugin-services
grails-plugin-servlets
grails-plugin-testing
grails-plugin-tomcat
grails-plugin-url-mappings
grails-plugin-validation
grails-resources
grails-scripts
grails-spring
grails-test-suite-base
grails-test-suite-persistence
grails-test-suite-uber
grails-test-suite-web
grails-test
grails-web
grails-webflow
maven
media
scripts
.cvsignore
.gitignore
.springBeans
INSTALL
LICENSE
README.md
build.gradle
build.properties
dependencies.txt
gradle.properties
gradlew
gradlew.bat
settings.gradle

README.md

Grails

Grails is a framework used to build web applications with the Groovy programming language. The core framework is very extensible and there are numerous plugins available that provide easy integration of add-on features.

Getting Started

You need a Java Development Kit (JDK) installed, but it is not necessary to install Groovy because it's bundled with the Grails distribution.

To install Grails, visit http://grails.org/Download and download the version you would like to use. Set a GRAILS_HOME environment variable to point to the root of the extracted download and add GRAILS_HOME/bin to your executable PATH. Then in a shell, type the following:

grails create-app sampleapp
cd sampleapp
grails run-app

To build Grails, clone this GitHub repository and then in a shell, type the following:

./gradlew install

License

Grails and Groovy are licensed under the terms of the Apache License, Version 2.0.

Something went wrong with that request. Please try again.