Require YAML files with Webmake
JavaScript Makefile
Switch branches/tags
Nothing to show
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
test
.gitignore
.lint
.travis.yml
CHANGES
LICENSE
Makefile
README.md
index.js
package.json

README.md

webmake-yaml

Require YAML files with Webmake

To use this extension, install it aside of Webmake:

$ npm install webmake-yaml

If you use global installation of Webmake, then extension also needs to be installed globally:

$ npm install -g webmake-yaml

When running Webmake, ask webmake to use it:

$ webmake --ext=yaml program.js bundle.js

Same way when Webmake is used programmatically:

webmake(inputPath, { ext: 'yaml' }, cb);

webmake-yaml can be used with any other Webmake extension, e.g.:

$ webmake --ext=yaml --ext=otherext program.js bundle.js

Programmatically:

webmake(inputPath, { ext: ['yaml', 'otherext'] }, cb);

Contributors

Big thanks to @puzrin (Vitaly Puzrin) for making a donation to Webmake project and making this extension possible.
Vitaly is a member of Nodeca team, that is behind js-yaml JavaScript YAML parser and dumper, and powerful social platform Nodeca.

Tests Build Status

$ npm test