Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

BUMP 1.1

  • Loading branch information...
commit 850159cd7cbaf0b80fd7d45e24a70a75f47e90cb 1 parent 36f45da
@banker banker authored
Showing with 5 additions and 6 deletions.
  1. +1 −1  ext/cbson/version.h
  2. +3 −4 lib/bson.rb
  3. +1 −1  lib/mongo.rb
View
2  ext/cbson/version.h
@@ -14,4 +14,4 @@
* limitations under the License.
*/
-#define VERSION "1.0.9"
+#define VERSION "1.1"
View
7 lib/bson.rb
@@ -2,10 +2,10 @@
$:.unshift(File.join(File.dirname(__FILE__), '..', 'lib'))
-MINIMUM_BSON_EXT_VERSION = "1.0.9"
+MINIMUM_BSON_EXT_VERSION = "1.1"
module BSON
- VERSION = "1.0.9"
+ VERSION = "1.1"
def self.serialize(obj, check_keys=false, move_id=false)
BSON_CODER.serialize(obj, check_keys, move_id)
end
@@ -55,12 +55,11 @@ module BSON
module BSON
BSON_CODER = BSON_C
end
- rescue LoadError => e
+ rescue LoadError
require 'bson/bson_ruby'
module BSON
BSON_CODER = BSON_RUBY
end
- p e
warn "\n**Notice: C extension not loaded. This is required for optimum MongoDB Ruby driver performance."
warn " You can install the extension as follows:\n gem install bson_ext\n"
warn " If you continue to receive this message after installing, make sure that the"
View
2  lib/mongo.rb
@@ -3,7 +3,7 @@
$:.unshift(File.join(File.dirname(__FILE__), '..', 'lib'))
module Mongo
- VERSION = "1.0.9"
+ VERSION = "1.1"
end
module Mongo
Please sign in to comment.
Something went wrong with that request. Please try again.