Skip to content
Permalink
Branch: master
Find file Copy path
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
103 lines (92 sloc) 3.94 KB
apply plugin: 'com.android.application'
android {
compileSdkVersion 28
buildToolsVersion '28.0.3'
defaultConfig {
applicationId "mega.privacy.android.app"
minSdkVersion 21
targetSdkVersion 28
versionCode 297
versionName "3.7.4 (297)"
multiDexEnabled true
ndk.abiFilters 'armeabi-v7a','x86', 'x86_64', 'arm64-v8a'
}
sourceSets.main {
java {
srcDirs += 'src/main/jni/mega/sdk/bindings/java/nz/mega/sdk'
srcDirs += 'src/main/jni/megachat/sdk/bindings/java/nz/mega/sdk'
exclude '**/MegaApiSwing.java'
}
jni.srcDirs = [] //disable automatic ndk-build
jniLibs.srcDir 'src/main/libs' // This is not necessary unless you have precompiled libraries in your project.
}
buildTypes {
debug {
// minifyEnabled false
// proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
}
release {
// minifyEnabled false
// proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
}
}
lintOptions {
checkReleaseBuilds false
// Or, if you prefer, you can continue to check for errors in release builds,
// but continue the build even when errors are found:
// abortOnError false
}
dexOptions{
jumboMode = true
}
compileOptions {
sourceCompatibility = 1.8
targetCompatibility = 1.8
}
// task megaSDK(type: Exec, description: 'Compile MEGA SDK via NDK') {
// workingDir 'src/main/jni'
// commandLine './build.sh', 'all'
// }
//
// tasks.withType(JavaCompile) {
// compileTask -> compileTask.dependsOn megaSDK
// }
}
dependencies {
implementation fileTree(dir: 'libs', include: ['*.jar'])
implementation 'com.android.support:appcompat-v7:28.0.0'
implementation 'com.android.support:support-v4:28.0.0'
implementation 'com.android.support:exifinterface:28.0.0'
implementation 'com.android.support:design:28.0.0'
implementation 'com.google.android.gms:play-services-wallet:16.0.1'
implementation 'com.android.support:recyclerview-v7:28.0.0'
implementation 'com.github.nirhart:parallaxscroll:1.0'
implementation 'com.android.support:palette-v7:28.0.0'
implementation 'com.google.firebase:firebase-messaging:17.3.4'
implementation 'com.google.firebase:firebase-core:16.0.5'
implementation 'com.android.support:cardview-v7:28.0.0'
implementation 'com.vdurmont:emoji-java:4.0.0'
implementation 'com.google.android.exoplayer:exoplayer:2.8.0'
implementation 'com.google.zxing:core:3.4.0'
implementation 'com.budiyev.android:code-scanner:1.8.3'
implementation "com.squareup.picasso:picasso:2.71828"
implementation 'me.leolin:ShortcutBadger:1.1.22@aar'
implementation 'com.brandongogetap:stickyheaders:0.5.1'
implementation 'com.github.bumptech.glide:glide:4.9.0'
implementation 'com.github.ittianyu:BottomNavigationViewEx:2.0.4'
implementation 'com.android.support:multidex:1.0.3'
implementation "com.android.support:support-emoji:28.0.0"
implementation 'com.android.support:support-emoji-appcompat:28.0.0'
implementation 'com.android.support:support-emoji-bundled:28.0.0'
implementation 'com.android.support:preference-v7:28.0.0'
implementation 'com.google.android.gms:play-services-location:16.0.0'
implementation 'com.google.android.gms:play-services-maps:16.1.0'
implementation 'com.google.maps.android:android-maps-utils:0.5'
implementation 'io.supercharge:shimmerlayout:2.1.0'
implementation 'net.opacapp:multiline-collapsingtoolbar:27.1.1'
implementation 'com.github.tony19:named-regexp:0.2.5'
implementation 'org.hamcrest:hamcrest-library:1.3'
implementation 'com.google.code.gson:gson:2.8.2'
annotationProcessor 'com.github.bumptech.glide:compiler:4.9.0'
}
apply plugin: 'com.google.gms.google-services'
You can’t perform that action at this time.