Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Superfish library for the Drupal Superfish module

branch: master
README
Superfish library

About:
------
This is the Superfish library for the Superfish module of the Drupal CMS.
http://drupal.org/project/superfish

The homepage of the jQuery Superfish plug-in is located at:
http://users.tpg.com.au/j_birch/plugins/superfish


Important:
----------
Do not modify any files of the Superfish library. The only acceptable change is addition of new CSS
files to the /style directory. Read the module README or the documentation for more information.


Requirements:
-------------
- jQuery version 1.3.x or later.
- jQuery version 1.6.1 or later if you are going to use the jQuery Easing plugin.


Contents:
---------
- superfish.js 
-- The jQuery Superfish plug-in version 1.4.8.
-- It is slightly modified mainly in order to make it compatible with screen reader software.
-- The original Superfish plug-in can be found on the homepage of the jQuery Superfish plugin.

- supersubs.js
-- The jQuery Supersubs plug-in version 0.3-beta.
-- It is slightly modified because of the Superfish module and some performance improvements.
-- The original Supersubs plug-in can be found on the homepage of the jQuery Superfish plug-in.

- supposition.js
-- The jQuery Supposition plug-in version 0.2.
-- It is heavily modified in order to work flawlessly.
-- The original Supposition plug-in can be found at:
   http://users.tpg.com.au/j_birch/plugins/superfish/supposition-test/

- sftouchscreen.js
-- The jQuery sf-Touchscreen plug-in version 1.3-beta.
-- It was developed as a part of the Superfish module.

- sfsmallscreen.js
-- The jQuery sf-Smallscreen plug-in version 1.1-beta.
-- It was developed as a part of the Superfish module.

- sfautomaricwidth.js
-- The jQuery sf-AutomaticWidth plug-in version 1.0-beta.
-- It was developed as a part of the Superfish module.

- jquery.hoverIntent.minified.js
-- The jQuery hoverIntent plug-in r6.

- jquery.bgiframe.min.js
-- The jQuery bgIframe plug-in version 2.1.2.
Something went wrong with that request. Please try again.