Skip to content
master
Switch branches/tags
Code

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
 
 
 
 
ide
 
 
 
 
src
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
RNNLIB is currently only tested for Linux and OSX.

Building it requires the following: 

- A modern C++ compiler (e.g. gcc 3.0 or higher)
- GNU Automake
- the NetCDF scientific data library. 
- Boost C++ Libraries (headers only)

In addition, the following python packages are needed for the auxiliary scripts in the ‘utils’ directory:

- SciPy
- matplotlib
- PIL

And this package is needed to create and manipulate netcdf data files with python, and to run the experiments in the ‘examples’ directory:

- ScientificPython (NOT Scipy)

To build RNNLIB enter the root directory and type

./configure
make

This should create the binary file ‘rnnlib’ in the ‘src’ directory.

If you wish to install the binary into another directory, type:

make install

By default this will use ‘/usr’ as the installation root (for which you will usually need administrator privileges).
You can change the install path with the —prefix option of the configure script (use ./configure —help for other options)

It is recommended that you add the directory containing the ‘rnnlib’ binary to your path,
as otherwise the tools in the ‘utilities’ directory will not work.

About

A recurrent neural network library for sequence learning problems.

Resources

License

Releases

No releases published

Packages

No packages published