Web page generation broken #610

Closed
purcell opened this Issue Mar 25, 2013 · 3 comments

Projects

None yet

2 participants

@purcell
Member
purcell commented Mar 25, 2013

From the location of the error, it looks like there's a package in the archive.json which isn't listed in the recipes.json:

Updating /home/melpa/melpa/working/pastels-on-dark-theme/
Wrote /home/melpa/melpa/packages/pastels-on-dark-theme-readme.txt
...kages/archive-contents locked by melpa@mantis.... (pid 4914): (s, q, p, ?)? 
package-build.el: `flet' is an obsolete macro (as of 24.3); use either `cl-flet' or `cl-letf'.
Loading /home/melpa/melpa/json-fix.el (source)...
package-build.el: `flet' is an obsolete macro (as of 24.3); use either `cl-flet' or `cl-letf'.
Loading /home/melpa/melpa/json-fix.el (source)...
index.html.erb:23:in `block in <main>': undefined method `[]' for nil:NilClass (NoMethodError)
    from index.html.erb:8:in `map'
    from index.html.erb:8:in `<main>'
    from /home/melpa/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/erb.rb:838:in `eval'
    from /home/melpa/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/erb.rb:838:in `result'
    from /home/melpa/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/erb.rb:820:in `run'
    from /home/melpa/.rvm/rubies/ruby-1.9.3-p194/bin/erb:137:in `run'
    from /home/melpa/.rvm/rubies/ruby-1.9.3-p194/bin/erb:158:in `<main>'
make[1]: *** [index.html] Error 1
make: *** [index] Error 2
@purcell
Member
purcell commented Mar 25, 2013

Not sure why the error occurred, but the recipes.json was not getting rebuilt properly. I've made the html gen a bit more robust too -- packages need to be listed in both recipes.json and archive.json to be included in the html index.

@milkypostman
Member

so, there was a problem a bit ago, after we switched to the new site, where index.html was not getting rebuilt. Basically, I discovered index.html was not in the .PHONY which I added in 3d138e6

Anyways, I suspect that this is in some ways related.

So was this causing a problem on the site or something local?

@purcell
Member
purcell commented Mar 26, 2013

The melpa.milkbox.net front page was just completely blank. :-/

@purcell purcell closed this Mar 26, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment