Skip to content
Newer
Older
100644 13 lines (10 sloc) 353 Bytes
9210458 Merged the 2 adapters into one : The correct one is loaded depending …
Guilhem Vellut authored Apr 28, 2006
1 class SpatialAdapterNotCompatibleError < StandardError
2 end
3
91b305e pour rails 2. probablement compatible avec rails 1.xxx
Guilhem Vellut authored Jan 24, 2008
4
d52b6e8 osme fix for postgis and rails2
Guilhem Vellut authored Feb 1, 2008
5 case ActiveRecord::Base.connection.adapter_name
6 when 'MySQL'
9210458 Merged the 2 adapters into one : The correct one is loaded depending …
Guilhem Vellut authored Apr 28, 2006
7 require 'mysql_spatial_adapter'
d52b6e8 osme fix for postgis and rails2
Guilhem Vellut authored Feb 1, 2008
8 when 'PostgreSQL'
9210458 Merged the 2 adapters into one : The correct one is loaded depending …
Guilhem Vellut authored Apr 28, 2006
9 require 'post_gis_adapter'
9b559a1 removing spaces
Mel Riffe authored Aug 4, 2008
10 else
9210458 Merged the 2 adapters into one : The correct one is loaded depending …
Guilhem Vellut authored Apr 28, 2006
11 raise SpatialAdapterNotCompatibleError.new("Only MySQL and PostgreSQL are currently supported by the spatial adapter plugin.")
9b559a1 removing spaces
Mel Riffe authored Aug 4, 2008
12 end
Something went wrong with that request. Please try again.