New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update via composer erzeugt Fehler #224

Closed
planepix opened this Issue Oct 3, 2017 · 3 comments

Comments

Projects
None yet
3 participants
@planepix

planepix commented Oct 3, 2017

Hallo,

Update einer 4.4.6 Installation und Contao Manager liefert einen Fehler.
Auch das Update via Konsole erzeugt folgenden Fehler:

[RuntimeException]
"/xxx/system/modules/multicolumnwizard" is not a link to "/xxx/vendor/menatwork/contao-multicolumnwizard/system/modules/multicolumnwizard" (expected "/xxx/vendor/menatwork/contao-multicolumnwizard/system/modules/multicolumnwizard" but got "/xxx/system/modules/multicolumnwizard")

Der Ordner /cache/prod/ wurde gelöscht.
Der Fehler wird auch danach angezeigt.

Aufruf des Composers: /usr/local/php71/bin/php composer.phar update
Hosting: netcup

@zonky2 zonky2 added the Defect label Oct 4, 2017

@planepix

This comment has been minimized.

Show comment
Hide comment
@planepix

planepix Oct 4, 2017

Update:
Geholfen hat, in den Verzeichnisses „/system/modules/” und „/web/system/modules/” den Ordner der Erweiterung „multicolumnwizard” und im Verzeichnis „/vendor/” den Ordner „/menatwork/” zu löschen.

Anschließend wieder das Composer Update ausführen und die Erweiterung wurde - ohne Fehler - neu installiert.

planepix commented Oct 4, 2017

Update:
Geholfen hat, in den Verzeichnisses „/system/modules/” und „/web/system/modules/” den Ordner der Erweiterung „multicolumnwizard” und im Verzeichnis „/vendor/” den Ordner „/menatwork/” zu löschen.

Anschließend wieder das Composer Update ausführen und die Erweiterung wurde - ohne Fehler - neu installiert.

@fritzmg

This comment has been minimized.

Show comment
Hide comment
@fritzmg

fritzmg Oct 4, 2017

Contributor

Der Fehler hat nichts mit dem mcw zu tun, sondern tritt auf, wenn das Composer Plugin nicht aktuell genug ist bzw. war. Ab Version 3.0.8 des composer-plugin tritt das nicht mehr auf.

Tritt der Fehler auf, muss man einfach nur die entsprechenden symlinks in system/modules manuell löschen - oder zuerst

composer update contao-community-alliance/composer-plugin

ausführen, bevor man

composer update

ausführt.

Contributor

fritzmg commented Oct 4, 2017

Der Fehler hat nichts mit dem mcw zu tun, sondern tritt auf, wenn das Composer Plugin nicht aktuell genug ist bzw. war. Ab Version 3.0.8 des composer-plugin tritt das nicht mehr auf.

Tritt der Fehler auf, muss man einfach nur die entsprechenden symlinks in system/modules manuell löschen - oder zuerst

composer update contao-community-alliance/composer-plugin

ausführen, bevor man

composer update

ausführt.

@zonky2 zonky2 removed the Defect label Oct 4, 2017

@zonky2

This comment has been minimized.

Show comment
Hide comment
@zonky2

zonky2 Oct 4, 2017

Contributor

@planepix dann kann das Ticket wieder zu - oder?

Contributor

zonky2 commented Oct 4, 2017

@planepix dann kann das Ticket wieder zu - oder?

@planepix planepix closed this Oct 4, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment