uninitialized constant Ambry::Model (NameError) #1

Closed
jonpauldavies opened this Issue Mar 23, 2012 · 2 comments

Comments

Projects
None yet
2 participants

getting this after installation

/Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/activesupport-3.2.2/lib/active_support/dependencies.rb:363:in `rescue in require_or_load': uninitialized constant Ambry::Model (NameError)
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/activesupport-3.2.2/lib/active_support/dependencies.rb:343:in `require_or_load'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/activesupport-3.2.2/lib/active_support/dependencies.rb:313:in `depend_on'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/activesupport-3.2.2/lib/active_support/dependencies.rb:225:in `require_dependency'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/railties-3.2.2/lib/rails/engine.rb:439:in `block (2 levels) in eager_load!'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/railties-3.2.2/lib/rails/engine.rb:438:in `each'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/railties-3.2.2/lib/rails/engine.rb:438:in `block in eager_load!'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/railties-3.2.2/lib/rails/engine.rb:436:in `each'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/railties-3.2.2/lib/rails/engine.rb:436:in `eager_load!'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/railties-3.2.2/lib/rails/application/railties.rb:8:in `each'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/railties-3.2.2/lib/rails/application/railties.rb:8:in `all'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/railties-3.2.2/lib/rails/engine.rb:434:in `eager_load!'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/railties-3.2.2/lib/rails/application/finisher.rb:53:in `block in <module:Finisher>'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/railties-3.2.2/lib/rails/initializable.rb:30:in `instance_exec'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/railties-3.2.2/lib/rails/initializable.rb:30:in `run'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/railties-3.2.2/lib/rails/initializable.rb:55:in `block in run_initializers'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/railties-3.2.2/lib/rails/initializable.rb:54:in `each'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/railties-3.2.2/lib/rails/initializable.rb:54:in `run_initializers'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/railties-3.2.2/lib/rails/application.rb:136:in `initialize!'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/railties-3.2.2/lib/rails/railtie/configurable.rb:30:in `method_missing'
    from /Users/jonpauldavies/Dropbox/sourcecode/Rails/codesonic/config/environment.rb:5:in `<top (required)>'
    from /Users/jonpauldavies/Dropbox/sourcecode/Rails/codesonic/spec/spec_helper.rb:8:in `require'
    from /Users/jonpauldavies/Dropbox/sourcecode/Rails/codesonic/spec/spec_helper.rb:8:in `block in <top (required)>'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/spork-1.0.0rc2/lib/spork.rb:24:in `prefork'
    from /Users/jonpauldavies/Dropbox/sourcecode/Rails/codesonic/spec/spec_helper.rb:6:in `<top (required)>'
    from /Users/jonpauldavies/Dropbox/sourcecode/Rails/codesonic/spec/models/user_spec.rb:23:in `require'
    from /Users/jonpauldavies/Dropbox/sourcecode/Rails/codesonic/spec/models/user_spec.rb:23:in `<top (required)>'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/rspec-core-2.8.0/lib/rspec/core/configuration.rb:698:in `load'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/rspec-core-2.8.0/lib/rspec/core/configuration.rb:698:in `block in load_spec_files'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/rspec-core-2.8.0/lib/rspec/core/configuration.rb:698:in `map'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/rspec-core-2.8.0/lib/rspec/core/configuration.rb:698:in `load_spec_files'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/rspec-core-2.8.0/lib/rspec/core/command_line.rb:22:in `run'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/rspec-core-2.8.0/lib/rspec/core/runner.rb:80:in `run_in_process'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/rspec-core-2.8.0/lib/rspec/core/runner.rb:69:in `run'
    from /Users/jonpauldavies/.rvm/gems/ruby-1.9.2-p318@codesonic/gems/rspec-core-2.8.0/lib/rspec/core/runner.rb:10:in `block in autorun'
Owner

tute commented Mar 23, 2012

You need to add gem 'ambry' to your project's Gemfile. I'll leave this open until it's no longer necessary. Thanks for reporting!

No problem, happy to help.

tute closed this in 1db7341 Mar 25, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment