Skip to content
This repository
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 18 lines (15 sloc) 0.54 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
##
# To run the test suite against all 3 rubies: 1.9.2, 1.8.7 and REE, simply run the following command:
# $ guard start
#
# Be use you are using RVM and have Ruby 1.9.2, 1.8.7 and REE installed as well as all
# Backup's gem dependencies for each of these Ruby intepreters.

guard 'rspec',
  :version => 2,
  :rvm => ['1.9.3', '1.9.2', '1.8.7', 'ree'],
  :bundler => true,
  :cli => '--color --format Fuubar' do

  watch(%r{^spec/.+_spec\.rb})
  watch(%r{^lib/(.+)\.rb}) { 'spec' }
  watch('spec/spec_helper.rb') { 'spec' }
end
Something went wrong with that request. Please try again.