New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

"Show x-axis" setting doesn't have any effect on small dashboard questions #7058

Open
brylie opened this Issue Mar 2, 2018 · 2 comments

Comments

Projects
None yet
3 participants
@brylie
Copy link

brylie commented Mar 2, 2018

I have created a bar chart that counts values by day. On the 'Question' page, the chart has X-axis labels:
screenshot from 2018-03-02 16-40-18

However, when adding the chart to a dashboard, the X-axis labels disappear:
screenshot from 2018-03-02 16-37-18

Here are the chart settings for the dashboard widget:
screenshot from 2018-03-02 16-41-14

Environment

  • Metabase version: 0.28.1
  • Metabase hosting environment: AWS
  • Metabase internal database: Postgres
@tlrobinson

This comment has been minimized.

Copy link
Member

tlrobinson commented Mar 9, 2018

I believe this behavior is intentional. If the question is 3 or fewer grid units tall we hide the X axis labels because there's not enough room to show them.

We should probably either hide that setting on dashboards or make it override the defaults based on the size.

@tlrobinson tlrobinson changed the title Date labels not appearing on dashboard timeseries chart "Show x-axis" setting doesn't have any effect on small dashboard questions Mar 9, 2018

@brylie

This comment has been minimized.

Copy link

brylie commented Mar 10, 2018

OK, thanks for your response. In the case of timeseries charts, the date labels are actually really important. Whereas the axis label is not so important, and could probably be hidden instead.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment