Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

No data displayed when pivoting data #8926

Open
wieki opened this issue Nov 12, 2018 · 9 comments

Comments

Projects
None yet
9 participants
@wieki
Copy link

commented Nov 12, 2018

With Metabase 0.30.4 and before pivoting a table worked by selecting 3 columns, where 2 columns were displayed and the last one was used as the information column at the intersections of column 1 and 2. With version 0.31 this seems no longer be working, the appreciated column selector works, but no data is displayed on the intersections.

Running Metabase 0.31.0 within Docker connected to a PostgreSQL database.

Steps to reproduce:

  • Create a question in table form, where 3 columns are selected for display
  • Select pivot and the pivoting column in the table settings
  • Metabase displays empty intersection where data should be

screenshot_pivot3

screenshot_pivot2

@wieki wieki changed the title No data display when pivoting data No data displayed when pivoting data Nov 12, 2018

@sapplaudience

This comment has been minimized.

Copy link

commented Dec 4, 2018

I'm experiencing exactly the same issue with Metabase 0.31.0 + PosgreSQL.

@mohit091

This comment has been minimized.

Copy link

commented Dec 18, 2018

Any update on this

@dgindin-cp

This comment has been minimized.

Copy link

commented Dec 28, 2018

Me too. No column data is displayed when I pivot the table. I am running Metabase v0.31.2. Any ETA on a fix? This bug is affecting one of our most important questions used for reporting. Thanks!

@wieki

This comment has been minimized.

Copy link
Author

commented Jan 22, 2019

Is there any timeline on updated pivot features? I see a number of PR/Tickets go around but no timeline when pivot functionality would work again?

@NicoBerthoz

This comment has been minimized.

Copy link

commented Mar 4, 2019

Would love to get this problem solved, would change my life. Thanks! (i +1 already)

@alex-mcleod

This comment has been minimized.

Copy link

commented Mar 12, 2019

I am also experiencing this issue. It seems to work correctly if the information in the cells is numeric, but other values are not displaying (e.g. text or dates).

@pulkitjalan

This comment has been minimized.

Copy link

commented Mar 26, 2019

Having the same issue v0.31.2, would be great to have this fixed.

@dgindin-cp

This comment has been minimized.

Copy link

commented Apr 2, 2019

Help! Please fix and I will send beer. :)

@muriloht

This comment has been minimized.

Copy link

commented Apr 10, 2019

the same on latest 0.34.2.

the pivot table works only when the data column is of type numeric.

If I want to show a "COUNT(*)" it's OK:

Activity Date 1 Date 2 Date 3
A-1 1 0 0
A-2 0 1 1
A-3 0 0 1

But if I try to show some text (customer name for example) the table is blank:

Activity Date 1 Date 2 Date 3
A-1 customer X
A-2 customer Y customer Z
A-3 customer X
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.