module page is missing entirely (was previously unindexed) #819

Closed
karenetheridge opened this Issue Apr 5, 2013 · 2 comments

Comments

Projects
None yet
3 participants
Contributor

karenetheridge commented Apr 5, 2013

Possibly related to CPAN-API#815

https://metacpan.org/module/MooseX::Storage gives an empty page, as if the module did not exist!

Last weekend I'd uploaded this dist but didn't have PAUSE permissions on all the modules, so it was not fully indexed by PAUSE. The module link worked at that time (going to the previous release, the last one that was indexed).

Today I got the permissions fixed and forced a reindex, and now the module link does not work at all! Is there some sort of caching issue?

Member

monken commented Apr 5, 2013

I guess you forced the reindex at pause.perl.org. We don't get notified about those reindexes and have to do it manually.Which I just did :)

monken closed this Apr 5, 2013

Contributor

karenetheridge commented Apr 6, 2013

On Fri, Apr 05, 2013 at 01:37:06PM -0700, Moritz Onken wrote:

I guess you forced the reindex at pause.perl.org. We don't get notified about those reindexes and have to do it manually.Which I just did :)

Ok, so if metacpan didn't think the latest version was indexed, shouldn't
the module link go the previous (last known indexed) release, instead?
It's wrong to show nothing at all for that module page.

monken reopened this Apr 11, 2013

ranguard closed this Dec 21, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment